Sangoma Remora A20004D PCI Card 8 FXO with EC problems

Hi Guys, got some issues with my card, right now the card works but I get some major echo problems.

Heres my settings, maybe im doing something wrong? Also right now im only use 6 lines for testing, but we do have a total of 10, and 8 max on the sangoma card, the other two are going to mega office all in one stations.

—Starts------------/etc/zaptel.conf-------------------

It must be in the module loading order

Span 1: ZTDUMMY/1 “ZTDUMMY/1 1”

Span 2: WRTDM/0 “wrtdm Board 1”

??: 1 WRTDM/0/0 FXSKS

??: 2 WRTDM/0/1 FXSKS

??: 3 WRTDM/0/2 FXSKS

??: 4 WRTDM/0/3 FXSKS

??: 5 WRTDM/0/4 FXSKS

??: 6 WRTDM/0/5 FXSKS

??: 7 WRTDM/0/6 FXSKS

??: 8 WRTDM/0/7 FXSKS

??: 9 WRTDM/0/8

??: 10 WRTDM/0/9

??: 11 WRTDM/0/10

??: 12 WRTDM/0/11

??: 13 WRTDM/0/12

??: 14 WRTDM/0/13

??: 15 WRTDM/0/14

??: 16 WRTDM/0/15

??: 17 WRTDM/0/16

??: 18 WRTDM/0/17

??: 19 WRTDM/0/18

??: 20 WRTDM/0/19

??: 21 WRTDM/0/20

??: 22 WRTDM/0/21

??: 23 WRTDM/0/22

??: 24 WRTDM/0/23

Global data

loadzone = us
defaultzone = us
fxsks=1-6
—Ends------------/etc/zaptel.conf-------------------

—Starts-------/etc/asterisk/zapata.conf-------------------
;
; Zapata telephony interface
;
; Configuration file

[trunkgroups]

[channels]

language=en
context=from-zaptel
;signalling=fxsks
rxwink=300 ; Atlas seems to use long (250ms) winks
;
signalling=fxs_ks
channel=> 1-6
;
; Whether or not to do distinctive ring detection on FXO lines
;
;usedistinctiveringdetection=yes
;hanguponpolarityswitch
relaxdtmf=yes
usecallerid=yes
hidecallerid=no
callwaiting=yes
usecallingpres=yes
callwaitingcallerid=yes
threewaycalling=yes
transfer=yes
cancallforward=yes
callreturn=yes
echocancel=yes
echocancelwhenbridged=yes
echotraining=800
rxgain=8.0
txgain=-4.0
group=0
callgroup=1
pickupgroup=1
immediate=no
busydetect=yes
busycount=3
;faxdetect=both
faxdetect=incoming
;faxdetect=outgoing
;faxdetect=no

;Include genzaptelconf configs
#include zapata-auto.conf

group=1
;fxsks=1-8
;channels=1-8
;Include AMP configs
#include zapata_additional.conf
—Ends------------/etc/asterisk/zapata.conf-------------------

—Starts------------/etc/asterisk/zapata-auto.conf-------------------
; Autogenerated by /usr/local/sbin/genzaptelconf – do not hand edit
; Zaptel Channels Configurations (zapata.conf)
;
; This is not intended to be a complete zapata.conf. Rather, it is intended
; to be #include-d by /etc/zapata.conf that will include the global settings
;
callerid=asreceived

; Span 1: ZTDUMMY/1 “ZTDUMMY/1 1”

; Span 2: WRTDM/0 “wrtdm Board 1”
; ??: 1 WRTDM/0/0 FXSKS
; ??: 2 WRTDM/0/1 FXSKS
; ??: 3 WRTDM/0/2 FXSKS
; ??: 4 WRTDM/0/3 FXSKS
; ??: 5 WRTDM/0/4 FXSKS
; ??: 6 WRTDM/0/5 FXSKS
; ??: 7 WRTDM/0/6 FXSKS
; ??: 8 WRTDM/0/7 FXSKS
; ??: 9 WRTDM/0/8
; ??: 10 WRTDM/0/9
; ??: 11 WRTDM/0/10
; ??: 12 WRTDM/0/11
; ??: 13 WRTDM/0/12
; ??: 14 WRTDM/0/13
; ??: 15 WRTDM/0/14
; ??: 16 WRTDM/0/15
; ??: 17 WRTDM/0/16
; ??: 18 WRTDM/0/17
; ??: 19 WRTDM/0/18
; ??: 20 WRTDM/0/19
; ??: 21 WRTDM/0/20
; ??: 22 WRTDM/0/21
; ??: 23 WRTDM/0/22
; ??: 24 WRTDM/0/23
—Ends-------------/etc/asterisk/zapata-auto.conf-------------------

—Starts-------/etc/asterisk/etc/wanpipe/wanpipe1.conf------------
#================================================

WANPIPE1 Configuration File

#================================================

Date: Fri Jul 14 21:22:06 PDT 2006

Note: This file was generated automatically

by /usr/sbin/wancfg program.

If you want to edit this file, it is

recommended that you use wancfg program

to do so.

#================================================

Sangoma Technologies Inc.

#================================================

[devices]
wanpipe1 = WAN_AFT_ANALOG, Comment

[interfaces]
w1g1 = wanpipe1, , TDM_VOICE, Comment

[wanpipe1]
CARD_TYPE = AFT
S514CPU = A
CommPort = PRI
AUTO_PCISLOT = NO
PCIBUS = 7
PCISLOT = 2
FE_MEDIA = FXO/FXS
TDMV_LAW = MULAW
MTU = 1500
UDPPORT = 9000
TTL = 255
IGNORE_FRONT_END = NO
TDMV_SPAN = 1

[w1g1]
ACTIVE_CH = ALL
TDMV_ECHO_OFF = NO
—Ends-------/etc/asterisk/etc/wanpipe/wanpipe1.conf-----

Make sure you enable Echo Cancellation using wancfg. Once you do so the last line in your cfg file will have: TDMV_HWEC = YES

Follow the instructions here: voip-info.org/wiki/view/Sang … figuration

ps. change the echotraining in your zapata.conf file from 800 --> no

Echo cancellation works perfectly for me. Here’s my zapata.conf:

[channels]

echocancel=yes
echocancelwhenbridged=yes

rxgain=8.0
txgain=-4.0
group = 2
signalling=fxs_ks
channel => 1-12

I’m using wanpipe-beta4-2.3.4.