[Resolved] Inbound OutBound not working x100p trunk

Inbound OutBound not working…
Ok guys, I have been at this for almost a week now and I still can’t get this card up.
I got a paypal donation ready for anyone who can help!
Trixbox 1.1.1 ran the update, finished great, this time I followed this install advice:
sureteq.com/asterisk/trixbox … ng_Trixbox

I thought it was a zaptel issue but when I run ztcfg it looks right, right?:

ztcfg -v

[size=59]
Zaptel Version: SVN-trunk-r1256
Echo Canceller: MG2
Configuration

1 channels configured.[/size]

Here is the rest of my config.

I turn on asterisk -vvvvvr then try to make a call to my pbx and I don’t see it coming in. When I try to make a call out, I get all circuits are busy now.

[size=75]# lsmod
Module Size Used by
md5 4033 1
ipv6 235137 12
autofs4 24773 0
i2c_dev 11329 0
i2c_core 22081 1 i2c_dev
sunrpc 162725 1
ztdummy 3924 0
wctdm 35136 0
wcfxo 13088 0
wcte11xp 28576 0
wct1xxp 19488 0
wct4xxp 286400 0
tor2 92064 0
zaptel 214052 11 ztdummy,wctdm,wcfxo,wcte11xp,wct1xxp,wct4xxp,tor2
crc_ccitt 2113 1 zaptel
dm_mirror 27825 0
dm_mod 57557 1 dm_mirror
uhci_hcd 31065 0
snd_au8820 31749 0
snd_pcm_oss 49017 0
snd_mixer_oss 17985 1 snd_pcm_oss
snd_pcm 96841 2 snd_au8820,snd_pcm_oss
snd_timer 29893 1 snd_pcm
snd_page_alloc 9673 1 snd_pcm
snd_ac97_codec 63889 1 snd_au8820
snd_mpu401_uart 8769 1 snd_au8820
snd_rawmidi 26597 1 snd_mpu401_uart
snd_seq_device 8137 1 snd_rawmidi
snd 55461 9 snd_au8820,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer,snd_ac97_codec,snd_mpu401_uart,snd_rawmidi,snd_seq_device
soundcore 9889 1 snd
8139too 25921 0
mii 5185 1 8139too
floppy 58481 0
ext3 116809 2
jbd 71385 1 ext3
[/size]

lspci

[size=59]00:00.0 Host bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (rev 03)
00:01.0 PCI bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX AGP bridge (rev 03)
00:07.0 ISA bridge: Intel Corporation 82371AB/EB/MB PIIX4 ISA (rev 02)
00:07.1 IDE interface: Intel Corporation 82371AB/EB/MB PIIX4 IDE (rev 01)
00:07.2 USB Controller: Intel Corporation 82371AB/EB/MB PIIX4 USB (rev 01)
00:07.3 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ACPI (rev 02)
00:0d.0 Communication controller: Tiger Jet Network Inc. Tiger3XX Modem/ISDN interface
00:0e.0 Multimedia video controller: Zoran Corporation ZR36120 (rev 03)
00:0f.0 Multimedia audio controller: Aureal Semiconductor Vortex 1 (rev 02)
00:10.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
01:00.0 VGA compatible controller: ATI Technologies Inc 3D Rage Pro AGP 1X/2X (rev 5c)[/size]
[root@asterisk1 ~]#
Zaptel.conf
[size=75]# Autogenerated by /usr/local/sbin/genzaptelconf – do not hand edit

Zaptel Configuration File

This file is parsed by the Zaptel Configurator, ztcfg

It must be in the module loading order

Span 1: WCFXO/0 “Generic Clone Board 1” RED

fxsks=1

Span 2: ZTDUMMY/1 “ZTDUMMY/1 1”

Global data

loadzone = us
defaultzone = us
etc/sysconfig/zaptel
[size=9]TELEPHONY=yes
#DEBUG=yes

Un-comment as per your requirements; modules to load/unload

genzaptelconf will populate this file

#Module Name Hardware
MODULES="$MODULES tor2" # T400P - Quad Span T1 Card

E400P - Quad Span E1 Card

MODULES="$MODULES wct4xxp" # TE405P - Quad Span T1/E1 Card (5v version)

TE410P - Quad Span T1/E1 Card (3.3v version)

MODULES="$MODULES wct1xxp" # T100P - Single Span T1 Card

E100P - Single Span E1 Card

MODULES="$MODULES wcte11xp" # TE110P - Single Span T1/E1 Card

MODULES="$MODULES wcfxo" # X100P - Single port FXO interface

X101P - Single port FXO interface

MODULES="$MODULES wctdm" # TDM400P - Modular FXS/FXO interface (1-4 ports)
MODULES="$MODULES wcfxs" # either above or this

#MODULES="$MODULES wcusb" # S100U - Single port FXS USB Interface
#MODULES="$MODULES wcfxsusb" # either above or this

#MODULES="$MODULES torisa" # Old Tormenta1 ISA Card

MODULES="$MODULES ztdummy" # UHCI USB Zaptel Timing Only Interface[/size][/size]

[size=59]Zapata.conf
;
; Zapata telephony interface
;
; Configuration file

[trunkgroups]

[channels]
busydetect=yes
busycount=6
language=en
context=from-zaptel
signalling=fxs_ks
rxwink=300 ; Atlas seems to use long (250ms) winks
;
; Whether or not to do distinctive ring detection on FXO lines
;
;usedistinctiveringdetection=yes

usecallerid=yes
hidecallerid=no
callwaiting=yes
usecallingpres=yes
callwaitingcallerid=yes
threewaycalling=yes
transfer=yes
cancallforward=yes
callreturn=yes
echocancel=yes
echocancelwhenbridged=no
echotraining=800
rxgain=0.0
txgain=0.0
group=0
"zapata.conf"[/size]

Thanks

Ok guys,
Made some change,
1, I copied this guy config for incoming.
2. and a big one, when I switched to a different computer, I also added in a bad splitter on the line when I switched to the new computer. The splitter was only giving battery on the port that went to the FXO Card and no dial tone. Thus never dialing out or in, I tried switching the line just in case and found as soon as I did, outbound and incoming work like a charm…
Dang and I am a phone guy, don’t tell anyone! :wink:

Updated content here too:
http://www.pbxinfo.com/forums/showthread.php?goto=newpost&t=19020