*RESOLVED* HELP - No Audio


#1

I am very new to Asterisk, but i have been working in comms since i learned to walk (almost) :laughing:

I have installed Asterisk 1.3(using asterisk@home) on VMware workstation 5. I also have a Windows host on the same virtual network, with Xlite softphone installed. There is no associated Hardware, I wanted it all to be VOIP.
My end goal is to set this up to communicate via H323 to a Voice Message platform.

I seem to be communicating with Asterisk, as i get NU for invalid numbers, busy etc. However, i don’t get any speech path. Firstly i tried setting up a recording in digital receptionist. I dial *77, but get no prompts, so i just speak for 30 secs & hang up. I then dial *99 to playback, but nothing happens, although both calls show as connected.

Next i tried setting up a test music on hold destination. Ext 6601 was unconfigured, & if dialed showed as invalid.

In zapdata.conf i have this entry:
musiconhold=default
In musiconhold.conf i have this entry:
default => quietmp3:/var/lib/asterisk/mohmp3

I then configured the following in the Ext-test secion of extensions.conf:
exten => 6601,1,answer
exten => 6601,2,waitmusiconhold(30)
exten =>6603,3,hangup

now when i dial 6601, i get an answer confirmation & 30 seconds later it clears down. All i hear though, is silence… :cry:

I looked in the logfile & it looks like the calls operate correctly & even shows MoH playing, but i hear nothing.

I hope someone can help me


#2

I don’t know how asterisk@home is configured, but you should start with an echo test, not music on hold. Music on hold isn’t necessarily the simplest thing to get working and it’s not the best thing to test your setup with.

Standard asterisk - i.e., not asterisk@home - comes with an echo tester configured in the dialplan on extension 600. A@h may or may not have it at that same extension. Whatever, get an echo tester working and test your setup with that.

There’s also a demo number, which might be worth trying before anything else. In the standard asterisk distribution it’s at extension 500.

There’s a reasonable chance that x-lite isn’t working properly.


#3

Thanks for the advice

It turns out that echo test is *43 on A@H. I searched through the A@H forum & found some pointers to issues with virtual USB hardware. It seems that it prevents the Zaptel drivers loading (which i confirmed by monitoring startup) I removed the USB virtual hardware & drivers, & now Zaptel starts & i can test echo with *43 & MoH on my test extesion.

All I need to do now is figure out how to set up H323 trunks to my Voicemail system :confused:

Any pointers greatly received.


#4

Have you read through the documentation on the voip-info site? Probably starting with:

voip-info.org/tiki-index.php … 3+channels


#5

Thanks i finally managed to get H323 installed once i figured out that it requires a live internet connection to download & install C++.