[Resolved] Help.....How to edit grub.conf to switch off ACPI


I installed CentOS 4.3 and was able to install Zaptel 1.2.6. But, when i run ztcfg -vv i am getting errors. also, my zttool does not showing any cards there. i have TE205P installed in the box. This forum disucssed some where to turn off ACPI that might be causing the problem. Please help.

Please see below output.

[root@astpbx ~]# cd /boot/grub
[root@astpbx grub]# cat grub.conf

grub.conf generated by anaconda

Note that you do not have to rerun grub after making changes to this file

NOTICE: You have a /boot partition. This means that

all kernel and initrd paths are relative to /boot/, eg.

root (hd0,0)

kernel /vmlinuz-version ro root=/dev/VolGroup00/LogVol00

initrd /initrd-version.img

title CentOS (2.6.9-34.0.2.EL)
root (hd0,0)
kernel /vmlinuz-2.6.9-34.0.2.EL ro root=/dev/VolGroup00/LogVol00 rhgb quiet acpi=off
initrd /initrd-2.6.9-34.0.2.EL.img
title CentOS (2.6.9-34.0.2.ELsmp)
root (hd0,0)
kernel /vmlinuz-2.6.9-34.0.2.ELsmp ro root=/dev/VolGroup00/LogVol00 rhgb quiet acpi=off
initrd /initrd-2.6.9-34.0.2.ELsmp.img
title CentOS-4 i386 (2.6.9-34.ELsmp)
root (hd0,0)
kernel /vmlinuz-2.6.9-34.ELsmp ro root=/dev/VolGroup00/LogVol00 rhgb quiet
initrd /initrd-2.6.9-34.ELsmp.img
title CentOS-4 i386-up (2.6.9-34.EL)
root (hd0,0)
kernel /vmlinuz-2.6.9-34.EL ro root=/dev/VolGroup00/LogVol00 rhgb quiet
initrd /initrd-2.6.9-34.EL.img

[root@astpbx ~]# cat /proc/interrupts
0: 53934 55390 IO-APIC-edge timer
1: 8 3 IO-APIC-edge i8042
2: 0 0 XT-PIC cascade
6: 3 4 IO-APIC-edge floppy
8: 1 0 IO-APIC-edge rtc
12: 54 12 IO-APIC-edge i8042
129: 2502 2711 IO-APIC-level aic7xxx, aic7xxx
161: 161 9 IO-APIC-level eth0
NMI: 0 0
LOC: 109046 109045
ERR: 0
MIS: 0

[root@astpbx ~]# ztcfg -vv
Notice: Configuration file is /etc/zaptel.conf
line 0: Unable to open master device ‘/dev/zap/ctl’

1 error(s) detected

[root@astpbx ~]# modprobe zaptel
[root@astpbx ~]# lsmod | grep zaptel
zaptel 196740 0
crc_ccitt 6081 1 zaptel

[root@astpbx ~]# uname -r

[root@astpbx ~]# uname -a
Linux astpbx.intelligroup.com 2.6.9-34.0.2.ELsmp #1 SMP Fri Jul 7 19:52:49 CDT 2006 i686 i686 i386 GNU/Linux

did u rebuild zaptel???

If you are on CentOS 4.3, the kernel source have a small bug you must fix.

sed -i s/rw_lock/rwlock/ /usr/src/kernels/uname -r-uname -m/include/linux/spinlock.h

cd /usr/src

find the zaptel-1.2.6 source
make linux26
make install
make config


modprobe zaptel
modprobe ztdummy

Then reboot your system: shutdown -r now.

Now log in as root again and type amportal stop and then genzaptelconf.
Reboot once more and you’re all set to go: shutdown -r now.

Hi bubba,

thanks a lot. it solved the problem. I wonder how this happend. i did edited spinlock.h file line 407.

amportal & genzaptelconf not worked for me as i am not using Trixbox (i guess).

Now i see zttool shows both my cards. Thanks again.

Just a question, how to backup asterisk configuration & is there any tool to take entire HDD image for quick restore?

Hi bubba,

One more question. Do you think that there is any interrupt conflict?


Go into the bio and disable anything u can serail ports LPT port onboard sound…DO NOT USB Turn off

With any kernal update to Linux u will be do ing the rebuild of ZAPTEL

you can use Storgrid vembu.com/ to backup to a remote server (with linux you can just backup the files)
You would want to reinstall the OS on any crash / rebuild as MANY patchs are coming everyday

asterisk is just a backup of the ect/astrisk folder

You should disable USB too if it’s not needed. It’s not required for timing on 2.6 kernel.

Thanks for the reply bubba & the.edge,

I am using dell poweredge 2300, i have to see how to disable those things. do i really need to edit /boot/grub/grub.conf file for ACPI? does my cat/proc/interrupts looks ok?

I dont have RAID on this server, i am looking for opensource based or freeware based imaging or backup software. I will check vembu.com today.

Thanks again for your time.

i don’t see any zaptel hardware there. what are you using ? or is it just ztdummy ?