[Resolved] GS 101 - Will not pickup when called from outside


#1

Hi all,

Just got a GS 101 in for testing and I am having problems getting it to pickup the line and bridge the call when a call is made to it.

  • I can dial out and ok.
  • The phone rings when the ext is dialed, just will not pickup.
  • Tried same settings with x-lite and works as supposed to.

I have read through the following:
voip-info.org/wiki/index.php … +budgetone

and specifically, the section:
"No sound when called with firmaware 1.0.6.3 ? " to no avail.

I believe I have the latest firmware: 1.0.8.16.

Any help would be great appreciated as I am ready to box it up and send it back.

Thanks :wink:


#2

Lee (is it?)

Would you like to see what the 101 HTML setup screen looks like on one of mine? Perhaps there is something in there that isn’t set right.

Let me know and I’ll put it up on my webserver and post a link.


#3

Brian,

Yes, it is Lee and Yes! I would love for you to post a copy of your html config screen.

Thanks for the help,

Lee


#4

Ok, Lee,

There are two files - one the basic settings screen and the other the advanced settings screen.

http://yugm.org/asterisk/bt101_basic.htm and http://yugm.org/asterisk/bt101_advanced.htm

It is working for me, but then they all (4 of them) worked from the start.


#5

Thanks Brian,

Unfortunately, that did not work. I guess it must be the phone. RMA time, I guess.

Thanks again,

Lee


#6

Do I understand you correctly that when a call comes into that extension, picking up the handset does not stop the phone’s ringing? Or is it something else?


#7

Yes, I can hear the GS 100 ring, but when I pick up…nothing. If I place the handset back on the cradle, it will continue to ring.


#8

Something interesting is that if I setup a softphone like x-lite with the same parameters as the hardphone, it works like it should.


#9

Wow, it’s always the little things.

Here is a snippet from sip.conf:

[general]
externip=xxx.xxx.xxx.xxx
localnet=192.168.0.0/255.255.255.0

The IP address of the phone was set 192.168.1.249. When I orginally entered the values, I thought that the IP address was acting as a mask as with the bindaddr property.

That was about 4 hours of my life I will never get back.

You live and you learn, LOL.

Thanks for your help Brian,

Lee


#10

Good work!

I’ve had some really unusual results from mistakes and just plain clueless things I’ve done in the setup department. Some of which I don’t want to even think about again.

Glad you got yours discovered and fixed. Now I’m thinking I might make a similar survey of my system trying to determing the cause of no audio coming in from one specific provider when setting up a SIP trunk with them. IAX2 works fine, and SIP trunks to other providers also work fine. Go figure.