[Resolved] Follow Me Script Help


#1

Hello all,

I have written the following asterisk script to dial my cell phone:

; -------------------
; extensions.conf
; -------------------
[globals]
AXTRUNK = SIP/axVoice
AREACODE = 910

[incoming]
exten => s,1,Answer()
exten => s,2,Wait(1)
exten => s,3,Background(tt-monkeys)
exten => 111,1,Playback(transfer)
exten => 111,2,Dial(Sip/111, 10)
exten => 111,3,Dial(${AXTRUNK}c/9105555555,20,r);
exten => 111,4,Voicemail(u111)

The problem that I have is that it falls through to the 4th priority with the following out put from the CLI:

=========================================================================
Connected to Asterisk 1.2.4 currently running on asterisk1 (pid = 2466)
Verbosity was 5 and is now 6
– Executing Answer(“SIP/datatrak-f421”, “”) in new stack
– Executing Wait(“SIP/datatrak-f421”, “1”) in new stack
– Executing BackGround(“SIP/datatrak-f421”, “tt-monkeys”) in new stack
– Playing ‘tt-monkeys’ (language ‘en’)
== CDR updated on SIP/datatrak-f421
– Executing Playback(“SIP/datatrak-f421”, “transfer”) in new stack
– Playing ‘transfer’ (language ‘en’)
– Executing Dial(“SIP/datatrak-f421”, “Sip/111| 10”) in new stack
– Called 111
– SIP/111-ad44 is ringing
– Nobody picked up in 10000 ms
– Executing Dial(“SIP/datatrak-f421”, “SIP/axVoicec/9102701560|20|r”) in new stack
[color=red] == Everyone is busy/congested at this time (1:0/0/1)[/color]
– Executing VoiceMail(“SIP/datatrak-f421”, “u111”) in new stack
– Playing ‘/var/spool/asterisk/voicemail/default/111/unavail’ (language ‘en’)
== Spawn extension (incoming, 111, 4) exited non-zero on 'SIP/datatrak-f421’
asterisk1*CLI>

I have highlighted the relevant event that shows congestion. I am using AXVoice for my sip provider and they have confirmed that I can have up to two different lines dialing out at the same time. I thought this was the problem at first, but if this is correct (which techs support at axVoice indicated) then it must be a configuration issue on my end.

Can anyone offer any ideas?

Thank you,

Lee


#2

Got it. I had originally tried the script found at:

voip-info.org/wiki/view/Aste … +follow+me

Which indicated:

"The c after the TRUNK command is what causes the connection to wait until the # key is pressed to complete the call. "

Referring to this line:

exten => 111,3,Dial(${AXTRUNK}c/9105555555,20,r)

However, when I took the “c” out, it worked correctly by dialing the number.

Lee