Register to sip provider

all I’ve configured my * serveur to register to a sip provider. and When i try to make a call I see a message “Decline” in my CLI.
I think i’ve configured my side properly
I’ve contact my provider and they that the problem is by my side because:
from my connexion log they can see that:

so my server ignor the unauthorise message.
They said that the connexion should be like this:

I have not get this error before.
I’ve three other different provider and there is no problem with them.
Plz help.
Best regards.

probably a NAT/firewall issue - your * is not getting “401 Authorization required” message from your provider

I’ve desable my firewall and my server is not behind Nat
here is my config section

type=peer               ;
secret=xxxxxx        ;
username=user       ;
fromuser=user        ;
host=    ;
port=5070              ;
authuser=user        ;
nat=no                   ;
allow=all                ;

Do you have register statement in sip.conf ?

Can you show your debug messages during the registration?

I had a similar problem … which may (or not) be related to yours.

It was caused by my provider requiring MD5 authentication … so i had to add the following to my declarations in sip.conf:


register => … @sip02…ca/MyDid

; SIP VoIP Account1

Check with you VoIP provider which authentication method they use …


I’ve add md5 section but still get the same error