Realtime PJSIP table ps_endpoint_id_ips

I have problem with realtime configurations table ps_endpoint_id_ips.
I try insert into values and have return conflict field column “match”, is a function in mariadb database!.
Someony can help me?

Server version: 10.5.15-MariaDB-0+deb11u1-log Debian 11

Files conf
extconf.conf
[settings]
ps_endpoint_id_ips => odbc,database

sorcery.conf
[res_pjsip_endpoint_identifier_ip]
identify=realtime,ps_endpoint_id_ips

±-------------±-----------------±-----±----±--------±------+
| Field | Type | Null | Key | Default | Extra |
±-------------±-----------------±-----±----±--------±------+
| id | varchar(40) | NO | PRI | NULL | |
| endpoint | varchar(40) | YES | | NULL | |
| match | varchar(80) | YES | | NULL |** |
| srv_lookups | enum(‘yes’,‘no’) | YES | | NULL | |
| match_header | varchar(255) | YES | | NULL | |
±-------------±-----------------±-----±----±--------±------+

What is that part? (On the match line in the Extra column?)

try quote the match using single quotes. the one to the left of the ‘1’ key.

I can’t tell you, but the issue is that the word “match” conflicts with a mariadb function =/

I’ve already tried.
Look at the return.
insert into ps_endpoint_id_ips(id,endpoint,“match”) values(‘21219999’,‘21219999’);
ERROR 1064 (42000): You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near ‘“match”) values (‘21219999’,‘21219999’)’ at line 1

id is missing

insert into ps_endpoints (id, transport, aors, auth, context, disallow, allow, direct_media) values (103, ‘transport-udp’, ‘103’, ‘103’, ‘testing’, ‘all’, ‘g722’, ‘no’);

wrong quotes. match

1 Like

i can’t type the proper quotes. this website auto-changes them into something else. it’s the one to the left of the 1 key.

"match" 'match'

Mark them up as pre-formatted text.

those are both the wrong quotes

If you are not getting:

image

that’s your browser, not the web site, or did you mean

`match`

image

1 Like

no i see it fine. i’m saying you used the wrong quote. You got it now though. The last one.

Used

image

And it worked. Thanks my friends! :star_struck: