Read command plays sound after passing

Hi everyone

In short here’s my problem.

Asterisk 11.2.1

I use Read to get the password from calling user and then the server goes on to do other things.
However the “input your password” sound plays 2 more times after the Read command has passed, later in the process. It is as if the Read command stays on loop in the background.

The same thing has worked perfectly in 1.4 and 1.6. I just recently upgraded to 11.2

the command itself is

exten => login,n,Read(var_password,welcome,4)

Verbosing it returns OK
– Executing [login@main_extension:10] Verbose(“SIP/X.X.X.X”, “1,OK”) in new stack

It also sounds as if the Read command is executed twice almost simultaneously. There is a small echo in the sound and it stutters and splutters too. Other sounds play fine until the welcome message comes haunting the lines again.

The verbose on the box does not show the command being executed more than once.

Any help and advices would be really welcome.

upgraded to 11.3 same problem continues

ok solved it.
World’s STUPIDEST mistake. had 2 asterisks running on different server taking calls from the same channel… DUH!