Queues broken in


I have been battling with Asterisk for quite a while now. I have set up some queues on a local extension. On the first incoming call to that extension the queue works as it should. But the second time the extension is dialed the queue application seems to crash, as it times out, with these symptoms:

  • All members of the queue are called simultaneously, but if the call is answered there is “nobody” at the other end.
  • Meanwhile the call it self proceeds through the dial plan as it should.

I have tried to switch to the SVN version, which actually solves the problem, but I cannot use the SVN version, since I need the BRIstuff patches (the problem is independant of the BRIstuff patches - have tested it extensively).

Please, if anyone can help me, I would really appreciate it!

Here is a sample dial-plan which crashes (ext. 1000 is for easy initialization):


exten => 1000,1,AddQueueMember(test|Sip/217)
exten => 1000,2,AddQueueMember(test2|Sip/217)

exten => 100,1,Queue(test||||5)
exten => 100,2,Queue(test2||||5)
exten => 100,3,Playback(vm-goodbye)



post your queues.conf

Here is my queues.conf (I have tried to make this setup as basic as possible for debugging my problem):

persistentmembers = no

timeout = 5
retry = 0
leavewhenempty = strict

timeout = 10