Problems with ATAPI drivers

So I’m having a problem with getting TAPI drivers to work correctly.

It’s not really the drivers themselves, as I’ve tested them in both Outlook and Dialer, and it works fine. But the software we’d like to use the TAPI with, which is called “Real Green” (for a lawn care company) does not seem to work properly with the drivers. The “Real Green” tech support claimed that its a problem with the drivers. They say it NEEDS to be a 32-bit driver, and the system itself is 64. We thought it might be a faulty driver(we were using the ActivaTSP driver from Sourceforge), so I tried another one this time it was a manual install driver, with both 32-bit and 64-bit drivers. Installed them, got it working great, and no luck. (Not sure if it makes a difference, but it told me to apply the 64-bit driver to System32, and the 32-bit driver to SysWOW64).

Like I said before, the claimed it needed to be a 32-bit driver to run properly in their software. However we attempted to install it on a x86 machine running 32-bit windows, and still no luck.

Anyone out there that can shed some insight?