Problems receiving SIP calls using Asterisk from Teliax

The setup we’ve been using for awhile now has been great, but within the past few days, when calling the phone number, we’ve been getting a busy signal. It may last for 5 minutes or less, then clears up and seems to be fine for an hour or less then starts again. At first we were using IAX through Teliax, but were encountering a similar problem. Tech support suggested switching to SIP and switching the codec to ULAW instead of GSM. The codec switch helped the call quality incredibly, but we’re still having this busy signal issue. Is there anything with Asterisk that could cause this? Or anything in the sip.conf or extensions.conf file that could do this? Or would a busy signal indicate a problem on Teliax’s side?

Asterisk is running on Debian Sarge on a Pentium II with 256MB RAM connected to a 3MB/896k Qwest DSL connection with a static IP.

Any ideas?

I have not had this trouble with my Teliax account, so far. As with anything internet related tho, my guess would be the connection between your asterisk box and Teliax. When this happens try pinging and/or traceroute to the proxy you are configured for and see if you have huge round trip times. I have been connected to one proxy and had to switch to an other sometimes due to this. Also if it happens frequently enough, set the verbosity in Asterisk to a larger number and watch the console. See if any message fly by regarding loosing connection. Also check /var/log/asterisk/messages for errors.

i saw this happening with iax yesterday. i would call the number and watch the cli and nothing ever happens. I will try again 1 minute later and it worked.

That’s exactly my problem as well. I toggle SIP DEBUG on in the CLI, and I see nothing when I get the busy signal. Teliax says they haven’t had any problems, and this problem is completely random. How do I set the verbosity in Asterisk to a higher number and what exactly does that do?

Again, is there anything I could have done in the extensions.conf for the default context that could have caused this?


increasing the verbosity level could result in seeing messages you didn’t see before (it’s possible a request did come in from teliax but you didn’t see it.) try:

set verbose 5

and see what you see…

I will give it a try later, when I’m there.

Just curious, which proxy is everyone connected to that is seeing this problem? What time did it last happen? I wonder if there is anything in commen? Hey, I might even be having the problem, but if nobody tells me they tried to call, I won’t know I missed it! Ha!

If the problem turns out to be with Teliax, then the more info we can give them the better.

I’m using “” in the Teliax control panel. I had problems last night, and Sunday around 3 or 4 PM.

this happens on and off at my location as well. it seems to concide with the following message appearing in the asterisk console, and clears up by itself within 20-30 seconds on average.

Dec 6 13:36:05 NOTICE[24562]: chan_iax2.c:7900 iax2_poke_noanswer: Peer 'teliax' is now UNREACHABLE! Time: 69 Dec 6 13:36:16 NOTICE[24562]: chan_iax2.c:7232 socket_read: Peer 'teliax' is now REACHABLE! Time: 99

i am on

do you have ‘qualify=yes’ for this trunk? if so, try turning it off. i’ve seen it cause problems before (at least for IAX, maybe SIP too?)

i do have ‘qualify=yes’ for this link, and i’ll try turning it off.

do i lose anything by disabling qualify? i haven’t had a reliability issue with teliax up to this point, so maybe i have nothing to worry about.

thanks for your assistance.

it isn’t real useful that i know of…

problem has not resurfaced since setting qualify=no. thanks.