Problem with Asterisk and Cisco 7942

Hello,
I bought a Cisco 7942G a few days ago unfortunately impossible to make it work correctly with Asterisk

Outgoing calls work fine with the phone, but incoming calls bring me back to voicemail directly.

When a call arrives at the PBX:

== Using SIP RTP TOS bits 184
== Using SIP RTP CoS mark 5
== Spawn extension (cos-all, 1003, 1) exited non-zero on ‘PJSIP/1003-0000006a’
== Everyone is busy/congested at this time (1:0/0/1)

Cisco 7942 configuration: <device> <deviceProtocol>SIP</deviceProtocol> <sshUserId>cisco</sshUserI - Pastebin.com

Incoming calls work great with Zoipper so why not with Cisco?

Many thanks in advance!

You would need to also provide the “pjsip set logger on” output to show the SIP signaling. That being said, you need to ensure “force_rport” is set to “no” on the endpoint, and you can’t enable any NAT stuff afaik. There may be Cisco config stuff to have it work, but I don’t know of that.

FYI…

IIRC, Ciscos of that vintage have a 31 character password limit.

Also, your ‘hastebin’ shows empty.

logger pjsip: (Deleted)
Cisco xml: <device> <deviceProtocol>SIP</deviceProtocol> <sshUserId>cisco</sshUserI - Pastebin.com

Sorry edited hastbin is down… :frowning:

That logging includes no call attempt that can be seen, and from the output it says no endpoint is found. It would be looking for an endpoint named “00270d3cd0ec”. That could just be the way the Cisco PUBLISH request works, though.

1 Like

No. They are from when the B leg is rejected. They include:

Warning: 399 Bad Request - ‘Invalid SDP information’

But because you start too late, we can’t see the INVITE with the SDP it doesn’t like.

1 Like

Sorry I think it’s better now: logs (Deleted)

You have AVPF enabled and the Cisco doesn’t support it. It’s the “use_avpf” option.

Thank you for your answer, I disable them in the configuration file of PJSIP Profile
The problem is still present. Here are the last logs! (Deleted)

It is not disabled. It is still present in the INVITE. You either modified the wrong thing, or it wasn’t reloaded.

5000 times thank you :heart_eyes: