Problem with app_queue, Asterisk not booting up

Hi guys,

I am running Asterisk now for many years ( on an old system), never had big issues, but this time I don’t know what to do: Asterisk does not boot up completely anymore. I tried everything, but there is nothing helpfull in the log (even with full debug enabled) and strace haven’t helped yet:
I have the following problem: With my std. configuration Asterisk does not boot up, so what I did as a first step is: I deleted all modules: Asterisk boots up, but with very limited options (even no sip!). So next step was: Use my Std. configuration, but this time with the default config files… No success. Then I used “make menuselect” to select only the modules I need. No success: Asterisk boots half way through and then stops. So “core set verbose 4” works, “sip show channels” not, and even “core stop now/gracefullt” not.
The big thing I changed in Asterisk was enabling, and using queues, so I disabled chan_agent and app_queue, and suddenly asterisk boots up fine, so my question is: what is in these two modules, that may keep asterisk from booting? (I have to disable both of them!) When I disable only one of them asterisk doesn’t boot. What I see is, when I enable app_que, nearly half of Asterisk is compiled again, when I enable chan_agent only chan_agent.c is getting compiled.

I have the suspicion, that is has something to do with some timers or threads…

Can anybody help me?
Even a tip on how to get a better debug, than enabling debug in the logger, or using strace, or maybe someone, who can read strace can help me?

Oh yes, when I compile asterisk with chan_agent (but without app_que) and then delete the module, Asterisk works, the other way around, so enabling app_queue (without chan_agent) and delete the app_queue module does not work.

I haven’t found any similar problem in this forums.

An another thing that’s strange: I had a running Asterisk version, and I just stopped and started Asterisk it afterwards, and from that day on it doesn’t work anymore.

I tried to compile Asterisk from scratch with Asterisk (which worked last time, but not anymore), and Asterisk (does not work either, same problem).

Please I need help, I don’t know what else to do. I need the queue module!


And the log files say ???

make sure full loging is enabled .



I have enabled everything in logger.conf, but I haven’t found any levels you can enable, like with the core set debug and core set verbose commands.