Problem loading wcfxo: ProSLIC 3210 version 2 too old?


#1

Greetings -

I’m a relative newbie to Asterisk, but a cranky old veteran of Linux. I managed to configure a fully functional system using an OEM X100P card. I quickly discovered that “soft phones only” wasn’t going to cut it for a production phone system so I ordered a brand new Digium TDM31B FXO/FXS card. After replacing the X100P I am unable to load the wcfxo module and the following errors appear in /var/log/messages:

Jun 2 14:45:07 asterisk kernel: ProSLIC 3210 version 2 is too old
Jun 2 14:45:07 asterisk kernel: Module 0: Not installed
Jun 2 14:45:07 asterisk kernel: ProSLIC 3210 version 2 is too old
Jun 2 14:45:07 asterisk kernel: Module 1: Not installed
Jun 2 14:45:07 asterisk kernel: ProSLIC 3210 version 2 is too old
Jun 2 14:45:07 asterisk kernel: Module 2: Not installed
Jun 2 14:45:07 asterisk kernel: Module 3: Installed – AUTO FXO (FCC mode)
Jun 2 14:45:07 asterisk kernel: Found a Wildcard TDM: Wildcard TDM400P REV E/F (4 modules)

and “modprobe wcfxo” returns:

/lib/modules/2.4.21-27.0.1.ELsmp/misc/wcfxo.o: init_module: No such device
Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
You may find more information in syslog or the output from dmesg
/lib/modules/2.4.21-27.0.1.ELsmp/misc/wcfxo.o: insmod /lib/modules/2.4.21-27.0.1.ELsmp/misc/wcfxo.o failed
/lib/modules/2.4.21-27.0.1.ELsmp/misc/wcfxo.o: insmod wcfxo failed

Needless to say, the FXS ports do not work and a Google search of “ProSLIC 3210” returns very little. A search of this forum returns nothing.

Any ideas? I don’t have a clue what the ProSLIC 3210 is…

TIA,
James


#2

upgrade to latest cvs stable or head. It is a new version of the fxs module on your card.


#3

I dont think the tdm card is using the fxo drivers, look around for something like wctdm or so in your zaptel directory.