PRI_CAUSE 17 trouble

Hi all!

My installation conststs of
(Meridian M11) <=E1=> (Asterisk with Sangoma A101)

Dial macro in extensions.ael looks like:
-------------- cut --------------

Dial(…);
switch(${DIALSTATUS}){
case BUSY:
PRI_CAUSE=XXX;
Hangup();
break;

-------------- cut --------------

So if a called extension is BUSY, that should hangup the caller with cause XXX. If XXX<>17 everything’s fine… I’m able to see it on Nortel’s D-chan… On Asterisk I could see
– Executing …Set(“Zap/27-1”, “PRI_CAUSE=XXX”) in new stack
– Executing … Hangup(“Zap/27-1”, “”) in new stack
or even Hangup(XXX);
– Executing … Hangup(“Zap/27-1”, “XXX”) in new stack
looks fine.

BUT if PRI_CAUSE equals to 17, the cause I see on Asterisk is 17, the cause I see on Meridian is 31 = “cause normal unspecified”…

Google’s told me about “priindication=outofband”… I’ve tried that with no success… I’ve found some unanswered topics of guys with same issues… So, now I’ve no idea to try =)

Asterisk is 1.4.17~dfsg-2ubuntu1
wanpipe is 3.2.7.1
zaptel is 1.4.10

Thanks is advance!

What signalling are you using? pri_net, pri_cpe or qsig? (or some other)
qsig is the lowest common denominator. try that.

Most PBXs can only be set for CPE (customer premise equipment) so I’m guessing you set asterisk as pri_net to act like the network side?

You can do pri debuging by settings from the CLI
CLI>pri intense debug on (look it up on google/voip-info)

or something like that - it’s a pain in the axx to go through

(edit: what version of libpri are you using?)

Thanks alot for your answer!
Nortel Meridian is unaware of qsig…

I didnt mentioned - it’s all OK with calling to/from Asterisk… no problems…
So…

>> pri intense debug span 1 looks like:

libpri is shown as 1.4.2-1ubuntu2

Yup. Sorry to bother you all…
Chris, thanks for the tips…

That was Nortel’s missconfiguration… :blush: