Playback doesn't work after upgrading from 1.0.1 to 1.0.7


#1

After upgrading from 1.0.1 to 1.0.7 none of recordings played using “background” or “playback” seem to work anymore, all I get is slience. No other changes were made to the comfiguration, just “make; make install”. The entire system is VOIP and I’ve tried it using IAX2 channel with Teliax and LiveVOIP providers with the same result. Downgrading to 1.0.1 fixes the problem.

Any ideas?

-Robert J Derr
WeatherFlow, Inc.

NO CARRIER


#2

Do you see anything out of the ordinary on the console when it should be playing something?


#3

No strage errors displayed from the console. I just get the normal message “-- Playing ‘custom/0’ (language ‘en’)”. I removed the jitterbuffer from iax.conf file, changed all the codecs to ulaw, deleted all the modules in /usr/lib/asterisk/modules before installing the new version and still no audio. I’m running out of options.

-Rob


#4

I figured it out myself. The problem was caused by ztdummy. I unloaded the module and everything works fine.

Thanks for all the help.

-Rob