Phone unable to connect to boot server

i have different subnet on my LAN. one subnet host the Asterisk server. all phone on that subnet works alright. however when i move a phone to anothe subnet, it is unable to connect to the boot server and i get this error.
" Could not contact the boot server using existing config"
what i have tried to do so far which haven’t worked

  1. taken the phone to the server subnet got it to work brought it back to the its orignal subnet and i get the same error
  2. i have also tried giving it a static IP also has not worked
  3. i have tried setting up a new phone from scrach still no show
  4. i have put the gateway address on there and also still no show
  5. i have even put the Vlan id of its subnet of the phone still not working
    i am rather new to this and i need help to get this phone to work on the other subnet

things i am very sure of

  1. i have checked and made sure that i can get to the asterisk server from the other subnet
  2. i can also ftp to the server from the other subnet

please Help am at a lost here