Parking Hints not working on 9133i

Asterisk version 1.4.20
Freepbx 2.4.0

I’ve set up BLF Parking for my asterisk server but am not getting lit confirmation on the phone.

include => parkedcalls
exten => 701,hint,park:701@parkedcalls
exten => 702,hint,park:702@parkedcalls
exten => 703,hint,park:703@parkedcalls
exten => 704,hint,park:704@parkedcalls
exten => 705,hint,park:705@parkedcalls
exten => 706,hint,park:706@parkedcalls
exten => 707,hint,park:707@parkedcalls
exten => 708,hint,park:708@parkedcalls
exten => 709,hint,park:709@parkedcalls

From the Asterisk CLI> core show hints,
It is telling me that 701 is in use when I park myself, (actually Iit shows it twice
701@from-internal-custom: park:701@parkedcalls State:InUse Watchers 0
701@park-hints : park:701@parkedcalls State:InUse Watchers 0

looks like I might not even of had to add the extension_custom.conf settings but it can’t be hurting can it?
Watchers 0 concearns me… my phone is able to use the system and all… just not getting the blf hint and I get no visual cue (red light) on the phone!

prgkey1 type: blf
prgkey1 value: 701
prgkey1 line: 1

Am I missing something??
This is outrageous and I demand a refund! :smile:

I figured this out… I have to reboot my phones if I reboot the server or they don’t get the hints…

Anyone know a fix for this? They’re aastra phones, not sure if everyone has this issue or just me.

You wouldn’t really want to have a blf for each call park slot. Besides that phone couldn’t show you a blf for each slot because there aren’t enough blf lights.

You can setup an xml key for park menu and have a park menu button to see what calls are parked.

You definitely should NOT have to reboot the phone everytime you make a server change. Only changes that modify the phone configuration files require a phone restart (generally speaking, there are some other odd cases but not in your situation).

I’m just setting up BLF for the first 3 or 4 parks… my client is used to using a key system and the staff are older and stubborn and “can’t” bother to remember a 3 digit number like 701

This is a know issue with Asterisk. The reason is that Asterisk does not fully follow RFC 3261 - unless you run it in pedantic mode (put “pedantic=yes” in the [general] section of sip.conf).

Thanks very much, I’ll try that out, does pedantic=yes do anything else to the system that I should know?

I’m sorry to say I really don’t know. I did see some mention of a DOS attack issue but have not had time to review it to see if it is current or an old warning. Sorry.