Park/Hold & Transfer w/ "remote extensions"


#1

Here’s our set-up:

We use a VPS to run * … each person in the company works out of their home and no one is physically connected to the network where * is running. When a customer calls our 800# and enters an extension, * dials one of our home office #s. For instance, extension 6001 dials me at 717-XXX-XXXX. We built our PBX using AMP as a front-end but are comfortable hand-coding the conf files.

  • has the ability to park/hold and transfer calls, but we have not figured out how to do this using these “remote extensions.” Each of us uses standard analog phones; some have service through PSTN while others use broadband (SunRocket, Vonage, etc.). We’ve tried without success the “#70” method for parking (yes, we activated this in our conf files) as well as the “*XXXX” transfer method. Alternatively, we’ve tried the “flash” or “hook” method on the phones, but this simply opens a new dialtone with our service provider, not *.

So, anyone have any experience with this? Can someone point us in the right direction? Is it even possible to park/transfer a call on a open line that is remote to *?

Thanks!


#2

Okay … so in doing more research, I realize the Dial cmd has the option for blind xfer built in for both the caller (T) and the called (t). I’ve also discovered that these options don’t seem to work when the Dial cmd is executed in a macro context. I did see a “patch” that was distributed about 2 years ago that supposedly resolves this issue, but it requires changing the source code and re-making the files. I’d like to avoid that and would be surprised that a patch from two years ago wouldn’t be included in the most recent stable version. Anyone have experience with this that they could share? Is there a work around? Is this fixed in the most recent versions (currently running 1-0-10/07/05-06:19:33).

In case this is related, when I watch the output from * when the inbound and the outbound legs are initially connected, I see this:

IAX2/jnctn_out/3 is making progress passing it to IAX2/jnctn@jnctn_out/2
IAX2/jnctn_out/3 answered IAX2/jnctn@jnctn_out/2
Attempting native bridge of IAX2/jnctn@jnctn_out/2 and IAX2/jnctn_out/3
Channel ‘IAX2/jnctn_out/3’ ready to transfer
Channel ‘IAX2/jnctn_out/2’ unable to transfer
Channel ‘IAX2/jnctn_out/2’ unable to transfer
Hungup ‘IAX2/jnctn_out/3’

Yes, the “unable to transfer” message does appear twice. Despite the “unable to transfer” and “hungup” messages, the inbound and outbound legs do connect and stay connected until one end hangs up. Is something interferring with * controlling the call (and hence then not able to respond to any input, e.g. the blind xfer command)/

Help, please! This is the last piece of the puzzle before we roll out our system. Thanks!