[P2P RTP Bridging][Dead Voice Issue]

Hi Users,
Currently i am facing dead voice issues in my asterisk server.
I have checked RTP debug and it says Sent RTP P2P packet to x.x.x.x:xxxxx
When i turn on mix monitor that p2p rtp issue vanishes(no voice issues), i have googled about the issue,
I know the bridging types in asterisk,
but my question is how can i change my bridge type, more specific how can i restrict asterisk not to send p2p rtp stream.
Note: t flag in dial command did not worked, i am not thinking of patching asterisk server(that could be the last choice).

Please help

Bilal Abbasi

For packet to packet with chan_sip, you must set directmedia=no, but not enable any sort of recording or anything that needs inband DTMF. I think out of band DTMF is OK with P2P.

Thanks David for your usual cooperation,
I did not mentioned that i am using inband DTMF INFO(this could not be changed as provider restrictions to use this).
Direct media is set to no.
canreinvite set to no.
But issue still persists, i have temporally added mix monitor so that my users did not face any issue.
But this is creating system load.

Bilal Abbasi

INFO is out of band. canreinvite is, at best deprecated, and may have been removed. MixMonitor will DISABLE P2P. I suspect you actually want to disable all bridging optimisations.

…and this is a discussion forum, not one for support questions.

TYPO.Yes its out of band.
And thanks for your cooperation…:smile:

Bilal Abbasi