Outbound Fax Failure 16.6.2-1 PJSIP Ata

After updating to 16.6.2-1; Outbound faxes from ATAs that are using PJSIP are failing to almost all destinations. Tried several different ATAs and Fax machines; downgrading to 16.4.1 fixes the outbound faxes. Outbound faxes from the fax server itself works fine on 16.6.2.

Note: As soon as downgrading to 16.4.1 is complete and the service restarted outbound faxes works fine.

Tested this several times. It failed 40 out of 40 test attempts to the HP Test Fax Number: 8884732963

ATA: Cisco ATA122
System: Freepbx

Has anyone else experienced this and do you have a workaround to make this work again with the latest build of Asterisk?

A change was done[1] to the fax gateway functionality to send reinvites out to both parties. This seems to have caused a problem in some deployments with faxing. An immediate fix is to remove the setvar on the PJSIP endpoint definition for FAX_GATEWAY. We’re also working on fixing this within Asterisk itself, which will come in a future release.

[1] https://gerrit.asterisk.org/c/asterisk/+/11422

1 Like

Interesting, glad to hear you are working on a fix. I had already tried removing the setvar of fax_Gateway and the faxes still failed. Guess I will have to stay on 16.4.1 for now.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.