OpenAIS and Asterisk


#1

Hi All,

I have 2 * boxes with 1.8.5.0 installed. I have also installed OpenAIS so I can have DDS working. When I start ais in the foreground with aisexec -f I can see both servers ok. This tells me that this part of the system is working ok.

My problem is in Asterisk on one of the boxes I have successfully loaded the res_ais.so module and can see the relevant commands in the Asterisk cli.

Every time I try and load the module on the second box, I get an error message saying ‘Could not initialize cluster membership service. Try Again’ which I have done. None of the ais commands are available in the Asterisk cli.

I have tried re installing Asterisk and checking through make menuselect that the res_ais module is there. Still doesn’t work

Any help would be great Thanks


#2

After a day and a half it would seem that running the install_prereq script which I needed to do to get the IAX2 channels working see here forums.digium.com/viewtopic.php?p=162582 has also performed a yum install of openias, which was not compatible with the openais and corosync I was using and trying to reinstall.

Performing a yum remove openais, then installing again via the make files fixed the issue.

Sorry forgot to say I’m using Asterisk 1.8.5.0