Obi202 : matching endpoint woes

I’m setting up an Obi202 to use with google voice.

Here’s the invite from the obi:

<--- Received SIP request (1077 bytes) from UDP: --->
INVITE sip:<mygv number>@ SIP/2.0
Call-ID: a74b229da0f3f096@
Content-Length: 267
CSeq: 8003 INVITE
From: <sip:+1<calling number>@>;tag=SP3f76347e37d776d50
Max-Forwards: 70
To: <sip:<my gv number>@>
Via: SIP/2.0/UDP;branch=z9hG4bK-1fff7d52;rport
Authorization: Digest algorithm=MD5,nc=00000001,qop=auth,cnonce="e9b330ab74be1ddb",nonce="1550095402/a91ccb1d87322dd50a035039fdaac528",opaque="17383dab1ff0ac1c",realm="asterisk",response="b66a3319031fa8e518f1e223516bcf93",uri="sip:<mygv number>@",username="gv-voice"
User-Agent: OBIHAI/OBi202-
Contact: <sip:gv-voice@>
Expires: 60
Supported: replaces
Content-Type: application/sdp

o=- 210161 1 IN IP4
c=IN IP4
t=0 0
m=audio 17002 RTP/AVP 0 101 104 8
a=rtpmap:0 PCMU/8000
a=rtpmap:101 telephone-event/8000
a=rtpmap:104 G726-32/8000
a=rtpmap:8 PCMA/8000

Here’s pjsip:

;; ====== Templates ====

type = endpoint
dtmf_mode = rfc4733
disallow = all
allow = ulaw
direct_media = no
;direct_media = yes
tos_audio = ef
tos_video = af41
cos_audio = 5
cos_video = 4

type = auth
auth_type = userpass
password = <pw>

type = aor
max_contacts = 2

; ===== endpoints  ========

auth = gv-voice
aors = gv-voice
context = gv-voice

username = gv-voice

But I get:

NOTICE[4148]: res_pjsip/pjsip_distributor.c:649 log_failed_request: Request 'INVITE' from '<sip:+1<calling number>@>' failed for '' (callid: fc53d8259e96576d@ - No matching endpoint found

I’ve tried identify_by = username and auth_username.

Any help appreciated.

For some reason the board doesn’t show some content.

  1. Each of the templates has “(!)”

  2. The gv endpoint, aor and auth have the respective templates in parens.

  3. And there is an aor : “[gv-voice] open parens obi202-aor close parens”

That’s because you didn’t mark it up as preformatted text.

ok, but how do I do that ? I’d expect this board would have lots of cut and pastes from .conf files. How do I turn on “preformatted text” ? (Quotes don’t work.) And, leave it on for all posts.

Hover over the tool bar until you see a likely option.

I don’t think you can.

See also Forum mishandles dialplans

Surround things w/ three backticks, e.g.: ```test```


the backticks to open can be on one line, the stuff on following lines, and the closing backticks on a further following line

Thanks. Will do. Never would have guessed it.

Any suggestions on the matching endpoint issue ?