Nothing recorded in asterisk on PRI channel

I’m using Trixbox 2.6 (Centos 5.5 Final, Asterisk, FreePBX). I’m using Digium’s TE110P PCI card where I plug my PRI line. The Record and Monitor commands in dialplan are working but they create an audio file with nothing in it. Here’s my simple dialplan to test recording:

[test_pri] exten => _X.,1,NoOp(WEATHER SYSTEM) exten => _X.,n,Answer() exten => _X.,n,Record(/DIALOG_SYSTEMS/PROTO_WEATHER_SYSTEM/input:wav,0,5,k) exten => _X.,n,HangUp() I'm trying to record for 5 seconds. The file is created and its size in not 0. but there is nothing recorded in it. I have tried it with Monitor command but the result was same.
Any help why it is not working?

I tried calling to PRI line and transferred that call to a softphone but before dialing the softphone, i play a welcome message. I can hear the welcome message when i dial the PRI line from a mobile, i also hear the dialing tone. Then i accept the call on softphone. After that, I cannot hear anything neither on softphone nor on mobile even when i’m speaking something.

Trixbox is not supported here and is using an old unsupported version of Asterisk.

Trixbox is not supported anywhere, as Fonality closed their peer support forums for it.