Not connecting/ringing to external extension

Hi All,

Hope you can help me.
I have Asterisk installed with freepbx on linux.
Eveything looks to be working fine, except for connecting / ringing a external extension on my mobile phone. I am using Zoiper as a softphone.
When i am connected with wifi inside the local network, all works. I can make a connection between extensions and my phone.
When i am connected through 3G/4G i can not make a connection from the internal extension to my phone. BUT i can make a connection from my phone to the internal extension.

Has someone encountered this problem before and solved it ?

Thank you,

what does the cli show when you make a call from internal ext to your mobile phone ext?

i got this (part) from asterisk log in freepbx;

WARNING[2796][C-0000001a] func_presencestate.c: PRESENCE_STATE unknown
WARNING[2796][C-0000001a] app_dial.c: Unable to create channel of type ‘SIP’ (cause 20 - Subscriber absent)

I am not an expert, but i can find my way to the switchboard in the darkroom if not then at least try. If I were in this position then I would take following steps to see whats goin on.

  • Check my port on the softphone on my mobile phone. (make sure its 5060, unless youve done port bind to different port)

  • Check what followin command shows in CLI. sip show peers

  • Then copy paste CLI when you make a call from external phone to internal phone.

  • I would also disable my phone’s network, then connect it to any wi-fi and then try makin a call.

For me these would narrow down the room to find possible flaw.

  • port on softphone is 5060

  • show peers ;
    Name/username Host Dyn Forcerport Comedia ACL Port Status Description
    1-pstn/1-pstn D No No 5061 OK (5 ms)
    100/100 D Yes Yes A 2599 UNREACHABLE
    101/101 D Yes Yes A 59829 OK (4 ms)
    3 sip peers [Monitored: 2 online, 1 offline Unmonitored: 0 online, 0 offline]

  • when connecting from external (softphone) to internal and internal is ringing, cli shows ;
    [2014-06-18 18:17:25] WARNING[3309][C-00000033]: func_presencestate.c:132 presence_read: PRESENCE_STATE unknown

  • when trying to connect to external, cli shows ;
    [2014-06-18 18:17:52] WARNING[3310][C-00000034]: func_presencestate.c:132 presence_read: PRESENCE_STATE unknown
    [2014-06-18 18:17:52] WARNING[3310][C-00000034]: app_dial.c:2437 dial_exec_full: Unable to create channel of type ‘SIP’ (cause 20 - Subscriber absent)

  • a notice every once and a while shows ;
    [2014-06-18 17:52:39] NOTICE[1795]: chan_sip.c:29480 sip_poke_noanswer: Peer ‘100’ is now UNREACHABLE! Last qualify: 0

in show peer 100, i can see the ip and port on the external phone.

Your external extension is 100? If yes then its not registering with your server… 100/100 D Yes Yes A 2599 UNREACHABLE

Unable to create channel of type ‘SIP’ (cause 20 - Subscriber absent)

Asterisk doesnt see your extension.

Try installing 3CX softphone for your mobile and see. I am sure it will work.

If that also doesnt work then check disabling your mobile network and route the registration through your wi-fi and see what results you get. also share them…

It is dynamic but has an IP address. That means it is registering. UNREACHABLE means that qualify is failing, i.e. qualify is enabled in sip.conf, but no replies are being received to the OPTIONs requests being sent. You will need to find out where they are getting lost.

If the phone is broken and ignoring them, you need to go to and ask how to safely disable qualify in FreePBX.

However, as it is registering from a public address, I suspect you have a NAT configuration problem. You may still need FreePBX specific help. My guess is you haven’t told Asterisk how to find its public address. That would, typically, be externhost or externip in native Asterisk.

i tried 3cx softphone, but it says unsupported pbx, need 3cx phone system 12. I started with this one, without luck, so turned to Zoiper.
It indeed has a ip adress, and is registered. I can make a call from the external phone to the internal.
All NAT settings have been set already.
So, after reading david55’s message, i tried the qualify setting for the extension. It was set to enabled and i set it to disabled. In sip show peers, the extension showed not monitored.
Tried to connect to it and it worked. Problem solved !
I have a working system now, thank you guys.