No sip noify after leaving vm msg in ver 1.8.5


#1

We went from asterisk 1.6.2.18 to 1.8.5 and
the sip notify for mwi does not go out upon leaving a vm msg.
Worked fine in 1.6.2.18 but that version has others issues(with mwi).
Is this a known problem for the 1.8 tree? (tried 1.8.6 also which did not work)
We use sip and vm realtime and ODBC for voicemail storage.
I see that there is a ticket,18002, that has been closed that once fixed this same type issue but the patch is in the code,
so did not help with our setup. Looks like to EVENT gets dropped.


#2

I found that the problem was with the SIP realtime facility.
Thats when I decided to uncomment rtcachefriends(defaults to ‘yes’) and set it to: rtcachefriends=no
and it now works. The linkedlist for MWI_EVENTS was not being updated correctly.
I will be looking into this further to see an external factor may have induced this.
I tested this on the production box(64 bit) and the workaround did not work. So more work to be done.


#3

After making sure of registering test phone after each asterisk restart as well as restarted
asterisk after changing rtcachefriends value, I see that it works with rtcachefriends=yes
and does not work with rtcachefriends=no.