No Echo But Background Static Noise

Ive managed to eliminate most of the echo using fxotune etc but when a call comes in I have to increase the volume on my phone and I hear a lot of background static. Ive checked the phone and its ok. Ive plugged in a normal phone and used BTs quiet line test and thats fine so it seems like the static is coming from asterisk. Calling asterisk mail etc does not have the static noise.

What can I do ? if I dont want to hear static I have the volume low but I cant hear the other party ? put the volume high and I can hear static !!!

I was getting the same kind of sound issue with a TDM2400 and my TDM400.

running the line test through Asterisk, is it still as noisy ?

are your modules setup for UK ? we use different line impedance here, it can make quite a difference.

after that i would start to suspect the module itself !!

How do I check its using UK and if not how do I set it?

the wiki should be your first port of call.

module wctdm needs to be loaded with option ‘opermode=UK’. this can be done manually, or specified elsewhere … e.g. on a RH-based system, /etc/modprobe.conf allows you to set permenant options for individual modules.

once done, run ‘dmesg’ to check the mode jthe module is loading in.

there are lots of tweaks to improve Asterisk use in the UK, again, search the wiki.