No DAHDI modules on the system. Not Starting. Needed for MeetMe in Asterisk 11

I have a running Asterisk 11 setup on Ubuntu (built from sources) - I have downloaded and installed numerous versions of Dahdi (tried a few older ones, currently trying 2.10.2 but also have tried latest).

They compile/build, but when I start dahdi it gives me the error:
No DAHDI modules on the system. Not Starting.

I do not have analog hardware installed, but need to install Dahdi in order to get MeetMe functionality working in Asterisk 11.

Did plenty of searching for solutions - there used to be a dahdi_dummy setup, but it is no longer needed (as Dahdi should provide the timers needed even if no hardware is found). No good if it won’t start though!

Help (and thanks in advance)!

Meetme is deprecated. There are conferencing applications that do the conference bridge in users space, so don’t need dahdi.

It sounds as though you built dadhi whilst running a different kernel from that on the production system. Check which directory actually contains the dahdi modules and compare its name with that of the running kernel (from uname).

Thanks for replying!

My real goal here is to use SLA - this uses Meetme, which in turn requires Dahdi.

I built both Asterisk 11 and latest Dahdi from sources, on the same Ubuntu box (so no kernel header mismatches).

Any ideas? There used to be a dummy Dahdi, but it is deprecated.

Try this :.

Ubuntu: sudo apt-get install linux-headers-uname -r
The use of uname -r surrounded by backticks (`) is for filling in the currently running kernel version so the appropriate package is installed.

I hope you are installing on a dedicated server and not VM

Hi ambiorixg12 - oh oh - I see trouble brewing…

The headers are installed (using uname trick etc) - this was necessary to build Dahdi.

I am running on a VirtualBox however - in fact I specifically bought an external ATA to avoid another box, drivers, using PCI cards etc… All devices, trunks etc connect via SIP, and so far it is working well on my VirtualBox.

So the elephant in the room - can SLA (with dependencies on Meetme and therefore Dahdi) run on a Virtual Ubuntu version of Linux?

Thanks (but dreading the reply).

The dahdi dummy processing is included in the core code. Dahdi will work for timing and conference bridging on a VM.

Have you confirmed that the modules have been built and are in the correct place?

Thought I would confirm that SLA works - my Dahdi problem was indeed due to conflicting headers (there were multiple linux source headers and the kernel got updated somewhere along the line).

Thanks for the help!