Native moh Add-ons problem

Please forgive me for rambling on but I don’t want anything lost in the translation:

I rebult one of my systems using Fedora 5.0 Core and got all the features I wanted * to do on my home system working, including the native moh without choppy playback. My girlfriend was really blown away when I put her on hold and her favorite mp3s started playing quietly in the background.

So I went back to my FreeBSD server, updated the ports and de-installed and then re-installed libpri and zaptel and then re-installed *

I had to comment out a few lines in the Makefile:
#WITHOUT_H323 = 1

I also had to add a line

to get it to build successfully. I then started up * and everything was fine with the exception of moh. The sound was choppy using mpg123 so I read the docs some more on the native moh at … nhold.conf.

This procedure worked fine on Fedora but not so on FreeBSD. The add-ons module crashed during the build. The last few lines of the add-ons build were this:

app_saycountpl.c:143: error: `ASTERISK_GPL_KEY’ undeclared (first use in this function)
gmake: *** [app_saycountpl.o] Error 1

I’m this close to having the * system I want on FreeBSD, my OS of choice. So can anyone offer some more pointers here?

BTW - Fedora is really cool. I hate to say it but the ease with which it setup X on my system was amazing. Not much to do other than update the packages after the install and then enjoy the attractive GUI it comes with.
Tell em user #49 sent you.

i havent gotten native MOH to work under freebsd either, i didnt have any compile problems though.

I had some confusion in the beginning but have been straightened out since then. My moh works fine now using the * native player instead of mpg123. You have to load the asterisk-addons port in order to get this working and make slight change to your mucisonhold.conf file.

The compile issue was resolved by simply adding the WITHOUT_FAX=1 line. The other lines I could’ve and should’ve left alone.

Right now I’m listening to the smoothest moh music through my speaker phone. I setup an extension just to listen to tunes. Works great.

My mp3 collection is stored on another FreeBSD server. The * box uses NFS to mount that drive and access my collection of more than 1000 mp3’s for a moh experience you just don’t find anywhere else.


what change did you make to your muscionhold.conf? i tinkered with it a little but it doesnt actually start playing music even though the CLI says it does.

In the default section of your musiconhold.conf file, or whichever section you are using add this line:



[quote=“maxfiles”]In the default section of your musiconhold.conf file, or whichever section you are using add this line:



unfortunatly, i already have that in my conf file. im setting up a test extension right now, we’ll see if it pans out.

its working now, perhaps asterisk hadnt been restarted after i added that to the muscionhold.conf file. not that it really matters, i dont have enough bandwidth to make music sound ok from the outside. :frowning:

I have the same problem, the moh doenst play everything compiles fine, but I just get silince, the console says


Executing Answer(“SIP/mysjphone-90e3”, “”) in new stack
– Executing SetMusicOnHold(“SIP/mysjphone-90e3”, “default”) in new stack
– Executing WaitMusicOnHold(“SIP/mysjphone-90e3”, “20”) in new stack[/code]

I added the mode=files

Any help would be appreciated…

We would need a little more information.

Did you install the add-ons port? You can’t run moh native without the add-ons port.


I installed the add-on port and uninstalled the mpg123 port, everything compiled fine no errors, I tired with format_mp3, rawplayer, even madplayer based on the sample config(just changed the paths) and nothing when I put on hold all I get is silence, the mp3s are in the right directory. I dont see any errors in the console, where else can I look ?

OK this the stranges thing, it didnt work on my laptop thats where I was doing all the * setup, but when I went to try it on my desktop and other PCs, it works fine go figure