My asterisk stops when i close ssh window

hi, today i update to the latest version of asterisk.

i run it with

#asterisk -vvvgcT

When i close my SSH window my asterisk stop,

if i open a ssh window and write:

#asterisk -r

it says that is not currently running…

what happend?

asterisk -vvvgcT starts it in a console that whats the c is for

just type asterisk or better still get it to start when the server starts.


ok, works but why?

in the previos version that works fine… now not.

who knows? maybe something was catching the signal that is killing asterisk when the window is destroyed. “doctor it hurts when i do X” “don’t do X!”


What version ? I dont know a single version that will work as you describe


every version, im on asterisk since 0.9, (abouyt 5 years ago) and i always start asterisk in the same way.

Well maybe now’s the time to look at scripting the start or a daemon like almost every one else does.

If you want to see why go to a server you have started your way and do a ctrl s and see what happens. then you will see why running on the console is not a good idea.