Modifying the Sip Via: Header

Asterisk 1.4.12 from source w/ freepbx
On a public ip w/ no NAT

I’m trying to set up a SIP trunk with Global Crossing and have run into a problem. It seems that their gateway has trouble with the received=ip address part of the Via header that Asterisk sends back with its 200 OK message.

So here is what asterisk is sending in response to their invite:

And this is what they would like to see:

Now it appears that asterisk is RFC compliant, but I’m still wondering if there is a way to modify this. I’ve tried all sorts of sip configuration options and none of them seemed to change this line. And from looking at the source code (I don’t really know C) it seems that the code for the received= line makes sure that it is always added.

Any help is greatly appreciated.