Media Attribute A-FAX

Hello Asterisk community.

I have a problem with my Asterisk 1.8.10 rc2.
My provider have a Huawei softswitch.

When i make a call,it funktions but If i want to FAX through G.711 the Asterisk has a Problem with the Huawei Softswitch.

I send the Invite to Huawei with codec G.711 and Port 11100.
Huawei accepts the invite, the FAX rings on the other side.
The Fax on the otherside takes the call and i get a re-invite form the Huawei with the Option t.38 - Port 11100,g711a - Port 11102,g711u - Port 11104.
On my Asterisk i have disable t.38, so the asterisk get the G.711 codec with the new Port 11102.
The Huawei does not switch to the new G.711 Port (Port 11102), an stay on the old Port 11100, because huawei send a media attribute a=X-FAX with the re-invite.
Asterisk accepts the re-invite, but does not send the madia attribute a=X-FAX, so the huawei ingnores the accepted reinvite and stays on the old Port 11100. But my Asterisk switches to port 11102.

How I can resolv this Problem?
Can i ingnore the re-invite from the Huawei?

Best regards.

X- means it is an unofficial extension. The Huawei should not be using it without prior agreement with you as to what it means.

Also note that for most SDP attributes, the process is not actually one of negotiation but of telling the other side ones capabilities (a=sendonly, recvonly, inactive are exceptions). However, with a non-standardised attribute, it is anyone’s guess as to how they should be used.


is there any way to tell Asterisk to send the X-FAX attribut?

Asterisk is open source.

The main difficulty will be that it will not remember that it saw X-FAX when it comes to construct the SDP response, so this is a low to medium complexity code change, not a trivial one, and you will need some programming skills.

Why don’t you simply enable T.38 on Asterisk?