Lumenvox issue with digit 4

Hi

I am have got one small niggle that is a real pain. My system keeps
reconising the digit 4 as a 0.

Basicly what I have a is a simple menu. that passes the call on to have an
account code recognised to check the caller has an account.

In the Menu I use the score to check the confidence of the recognition. if
its above 350 I pass the call on, otherwise I pass it back.
Once they get to the account code they are asked to say the code. and whats
happening is that if they say for examle 41234 the dialplan reads it back to
let the caller check it and its often 01230, I cant use the score as its
high normally around 600, and DTMF works fine.

Its obviously mixing four up with nought i Guess. Is it possible to remove
nought and make callers say zero ? or does anyone have any other Ideas ?

Did the digits grammer get messed up some how? I can’t see how “four” would be processed as “zero”. You may want to use the lumenvox tool to look at the audio file.

The problem seems to be that in the default .gram file it has ZERO and 0, with the 0 in there 4 is reconised as 0 with i removed all is OK.

This does need looking into in more detail. I will be doing that over the next few days.

Ian

I’ll give it a try also here with my install.

Hi

I will PM my conf for you to look at.

Ian

Everything looks fine with the conf. I reconfigured my install and when I say “four” it properly matches and goes to extension “4”. I’m using engine 7.1 with connector 7.1. Not sure if that would make a differences. We are both using the same ABNFDigits grammer and there’s nothing that I see in the dialplan that would screw up what it detects. I would suggest running the sound file through their program thing.

-- Executing NoOp("SIP/johntest-08698498", "SpeechScore = 746") in new stack
-- Executing GotoIf("SIP/johntest-08698498", "0?:4|1") in new stack

Hi

Do you have the O and zero in the 0 or just zero ? as reming it solved it.

I think it may be a prununciation issue, Im not 100% sure how 4 is pronounced in The US compared to the UK.

I will email support.

I know when I worked on Wildfire digits were always an issue until localised for the indevidual markets.

Ian

This grammer straight from Lumenvox works fine when saying “four” for me.

#ABNF 1.0 UTF-8;
language en-US;
mode voice;
tag-format <lumenvox/1.0>;

root $Digits;
$Digit = (ONE:“1” |
TWO:“2” |
THREE:“3” |
FOUR:“4” |
FIVE:“5” |
SIX:“6” |
SEVEN:“7” |
EIGHT:“8” |
NINE:“9” |
(ZERO | O):“0” );

$Digits = {$=’’} ($Digit {$+=$$})<1->;