Loud click 1 second into all PSTN calls

for whatever reason, we get a loud click about 1 second into every PSTN call. the click occurs on the receiving end of the channel (i.e. anyone who calls us or whom we call gets silence 1 second into the call, we get the loud click/squeal).

This started about 2 months ago, when we changed offices.

-We are running 1.4.1 of asterisk and zaptel.
-our phone service is through Nuvox
-We have two TDM400 modules with 6 PSTN lines (4 in one, 2 in the other).
-all phones are SIP phones (Linksys 941).
-I have run fxotune and all echo cancellation steps I could find. I’ve also verified signal levels on a 1004 loop line
-the problem occurs if I call directly into the attendent or directly into voicemail
-the problem does not occur if I connect an analog phone directly into the jack, only on the asterisk lines.

Any suggestions as to where to go from here to diagnose the problem would be greatly appreciated.

You can hear a click when echotraining is enabled but it shouldn’t be a sqeal.

perhaps the gain is too high on the channel ? although wouldn’t it have to be really high to turn a tap into a squeal ?

The sound is best described probably best described as somewhere in between (a “squeak” perhaps). it is loud enough that you have to take the phone away from your ear.

–[zaptel.conf (entire file)]–


;define channels
channel => 1
channel => 2
channel => 3
channel => 4
channel => 5
channel => 6
[end excerpt]

-in case you’re wondering, I set each channel separately to diagnose the problem and make sure it wasn’t any single module/line.
-If the echotraining is set lower, we get a lot of echo AND the squeak.
-I’ve turned echocancelling off and we still get the squeak.
-the hardware is unchanged from before the problem and I’ve tried pulling each card to see if it was a card issue.

the following might be helpful:
-our service (Nuvox) comes in on a T-1 that is split at a Cisco 2431 router into 8 analog voice channels and the remainder to data
-the voice channels are terminated to a punchdown block.
-6 of those channels go to the asterisk box
-the other two go to fax machines
-the fax machines don’t get the squeak.
-If I plug an analog phone into any of the ports, no squeak, either.

i was having a similar problem with my aastra phones. the only thing that i found to get rid of it was changing the codecs used.

I really don’t think it is our phones. When I plug an analog phone into any of the lines, the problem doesn’t exist. I’m assuming it is something from the digium cards forward.

I’m willing to give it a shot, though. What codec are you using? we are set for G711u.