Lost packet numbers

I know there is a way to create a log which contains various information about the running asterisk network, with information such as lost packets. I’ve seen people posting their statistics for troubleshooting, etc.

I just have no idea what the command function is, or if I need to install any additional software to get it working. I’ve been surfing the internet for a long time and I cant find anything relevant for asterisk 1.6.

Any information you can give is highly appreciated
Thanks

help rtcp

Ive put that in, and i enabled both options that were listed.

However, I see no noticeable change. Is it being logged into a file somewhere? If so, where is the directory this file is located?

Thanks for your reply.

You may need to adjust logging.conf to have debug output sent to the right place(s).

I have changed various options inside the logger.conf file and the only thing that I have managed to change is the new file “debug” that is created inside the log directory. This file contains:

Theres nothing mentioning RTCP anywhere that I can see. Perhaps something is wrong with the way I installed asterisk?

It seems it’s verbose, rather than debug, output (I’ve got verbosity 3, so it is no more than that):

[2009-08-19 12:54:39.610] VERBOSE[16839] rtp.c: RTP-stats [2009-08-19 12:54:39.612] VERBOSE[16839] rtp.c: * Our Receiver: [2009-08-19 12:54:39.612] VERBOSE[16839] rtp.c: SSRC: 3819912237 [2009-08-19 12:54:39.612] VERBOSE[16839] rtp.c: Received packets: 1003 [2009-08-19 12:54:39.612] VERBOSE[16839] rtp.c: Lost packets: 0 [2009-08-19 12:54:39.613] VERBOSE[16839] rtp.c: Jitter: 0.0002 [2009-08-19 12:54:39.613] VERBOSE[16839] rtp.c: Transit: 0.4058 [2009-08-19 12:54:39.613] VERBOSE[16839] rtp.c: RR-count: 0 [2009-08-19 12:54:39.618] VERBOSE[16839] rtp.c: * Our Sender: [2009-08-19 12:54:39.619] VERBOSE[16839] rtp.c: SSRC: 1331939574 [2009-08-19 12:54:39.619] VERBOSE[16839] rtp.c: Sent packets: 899 [2009-08-19 12:54:39.620] VERBOSE[16839] rtp.c: Lost packets: 0 [2009-08-19 12:54:39.620] VERBOSE[16839] rtp.c: Jitter: 0 [2009-08-19 12:54:39.620] VERBOSE[16839] rtp.c: SR-count: 4 [2009-08-19 12:54:39.620] VERBOSE[16839] rtp.c: RTT: 0.000000

Im not getting any verbose messages at all.

Ive managed to get a huge list of debug messages, but not a single verbose one. There must be an option I am missing.

core set verbose n

verbose set to 3

However, there are still no verbose messages appearing.

Actually, I had verbose set to 0, so, even though it is tagged VERBOSE, it isn’t the consequence of verbosity.

I have these settings in logger.conf, and get the information on the console:

;debug => debug console => notice,warning,error ;console => notice,warning,error,debug messages => notice,warning,error full => notice,warning,error,debug,verbose

Ive got those exact settings inside my logger.conf file. This is odd! Is there anything else which could be preventing them?

Sorry for the double post, but ive run “agi show verbose” on the command line and I got this:

*CLI> agi show verbose Usage: VERBOSE <message> <level> Sends <message> to the console via verbose message system. <level> is the the verbose level (1-4) Always returns 1. Runs Dead : Yes

Is it supposed to be set as “Runs Dead:Yes”? Sounds like its turned off.