Linphone Codecs problem

My place of business has an Asterisk test server that I have appropriately registered VOIP phones and can make internal ext. and outgoing calls without issue.

I am doing some testing within the dialplan (more learning than testing since I am a dialplan coding noob) and I wanted to use Linphone to make internal and outgoing calls so I am not dependant on the Aastra voip phones.

I have made the Node entry for my Linphone install and can make calls out to my voip phone here at the office, however when I pick up the receiver, I receive the following error within Linphone:

“Incompatible, check codecs or security settings…”

I have the following OS platform:

  • Windows 7 Pro 64 bit

The following codecs that I have listed and are enabled are:
[ul]PCMA
PCMU
GSM
G722
speex (two different rates)
L16 (two different bit rates)[/ul]

A colleague of mine suggested installing the G.711 codec, which I attempted from Microsoft’s web
codec.alshow.co.kr/Page/en/g711.htm, however Linphone still fails and I still don’t see the g.711 codec option in my list.

I have tried disabling all but the PCMA and PCMU, same issue. I have moved each codec to the top of the list thinking that priority might matter…no effect.

I have watched the CLI console and the problem seems to be on the linphone side…I can call Voip phone to Voip phone or call from voip phone to external without issue.

If anyone can point me in the right direction, it would be much appreciated.

Enable the sip debug to see the sdp transaction. The command in asterisk cli is sip set debug on.

The first two options on your list are G.711.

Disable “Always use Video” in linphone. It helped me.