LDAP with oxymium

Have anyone tried oxymium ( free.oxymium.net/Asterisk/ )?

I have SLES10 with LDAP Account Manager (LAM) and the objectClasses aren’t showing up? I suspect the schema file. I tried the other LDAP plug-in called Astirectory and the schema was working for that one though I couldn’t get anything to work.

The only thing I got working was the LDAPget. I am curious on other people’s experience with it.

Have anyone tried Astirectory from asterisk-ev.org/astirectory.php? I configured and compiled it and it connects to ldap just fine. The sip peer’s context from the LDAP accounts are not honored. An example: John Doe entry in LDAP has a context of testing and the extensions.conf has:

exten = 111,1,Answer()
exten = 111,n,SayNumber(1)
exten = 111,n,Hangup()

exten = 112,1,Answer()
exten = 112,n,SayNumber(2)
exten = 112,n,Hangup()

The 111 extension can be accessed but not the 112. I am using Asterisk 1.2.16.

Concerning the context of the sip peer, there must be an attribute of astname since the query to fetch a sip peer in LDAP is code[/code]

Also, I had to modify a small change in the source code in:
static struct ast_variable *realtime_ldap(…)

The change is strncat(query2, "&", sizeof(query2)-1); into

strncat(query2, "(&", sizeof(query2)-1); since without that change, we will get malformed LDAP queries without the leading left parenthesis.

Now, Astirectory works with sip entries in LDAP.