Kubunti 12.10, Asterisk and Quick Start Guide

Sorry if this appears to be a duplicate post, I wrote a long winded post earlier and it went to never-never land.

I’m trying to make Asterisk 1.8.x work, spent 3 weeks and have a single PC running Asterisk 1.6.x running under Kubuntu that worked perfectly according to the quick start guide. Even got Realtime and PHPAGI working so I decided to ‘finesse’ it.

When I build Asterisk I seem to have full success. When I try to use the Quick Start Guide to test IAX and such, I cannot connect with the dialplan command Dial(IAX2/guest@pbx.digium.com/s@default)

I thought perhaps that some of the default IAX settings might be required so I reverted back to all the sample .conf files and modified sip.conf to let zoiper connect in the demo context and tried the 500 extension defined in the sample extensions.conf Dial(IAX2/guest@misery.digium.com/s@default) and still no luck.

Enabling IAX debugging, I see codec issues. Since I know GSM seems to be the preferred codec that worked under Asterisk 1.6, I tried ‘disallow=all’ and ‘allow=gsm’ in the IAX.conf, still no luck.

I should note that festival, sip, realtime and agi all appear to be working and I’m not getting any obvious errors. IAX is attempting to make the connection.

If it was a firewall issue, opening the ports on my firewall and such should have worked. The Asterisk 1.6 host works fine without this step.

On some other forums, I noticed an issue with Asterisk 1.8.3 and above connecting to older IAX hosts… Is this what I am having a problem with? Are pbx.digium.com and misery.digium.com running versions of Asterisk that are not compatible with Asterisk 1.8.3.x and above?