JABBER: socket read error

I’m seeing an interesting log warning which then results in one-way audio in our Asterisk system. The error is:

I’ve followed these instructions (http://www.voip-info.org/wiki/view/Asterisk+Google+Talk) in terms of getting gnuTLS installed (it was lacking on my system) but the warning still shows. It happens roughly two or three times a day and is not immediately reproducible.

I’m able to fix the one-way audio by restarting the Asterisk process.

The current running version of Asterisk is 11.0.1.

Any suggestions on things to check?

I’m still seeing this error resulting in the audio problems. This bug report seems to be exactly what I’m seeing: issues.asterisk.org/jira/browse/ASTERISK-20453

Can I help provide debug/logging information?

EDIT: I’m now running the latest Asterisk (11.2.0 as of this writing) and still seeing this problem.

I have seen the same error using 11.2.0. Also 1.8.19.1 shows the same error but Google calls in/out work fine. 11.2.0 requires to restart to able to make Google calls.