I’ve tried to add intercom=true to SIP_URI_OPTIONS but it doesn’t get sent on INVITE.


exten => _X.,1,Set(SIP_URI_OPTIONS=intercom=true)
exten => _X.,n,Dial(SIP/102)

And the INVITE line doesn’t contain the added parameter:

Asterisk v

Any idea how to get it to work?

Tnx in advance!

Try this:

exten => _X.,1,Set(__SIP_URI_OPTIONS=intercom=true)
exten => _X.,n,Dial(SIP/102)

Malcolm, tnx for your help!
It works :wink:

If anybody else runs into similar, just google asterisk inheritance of channel variables.

Malcolm tnx again for your quick response.

You’re very welcome. :smile:

The reasoning:

You need the dialed channel, not the calling channel, to inherit the variable’s settings.