Incompatible in Asterisk 1.6

Asterisk 1.6 beta 6 + addons beta 2 = ok

Asterisk 1.6. beta 7.1 + addons beta 2 = error

All modules from addons beta 2 give error mesage (not loading) on Asterisk 1.6. beta 7.1

Anybody else ?

Can you try beta-3? It was tagged yesterday. May help resolve your issue.

svn.digium.com/view/asterisk-add … 6.0-beta3/

I want to test it… Not sure how to do this from the SVN…


root@core:/kituri/voip/asterisk-1.6# svn co svn.digium.com/view/asterisk-add … 6.0-beta3/
svn: PROPFIND request failed on '/view/asterisk-addons/tags/1.6.0-beta3’
svn: PROPFIND of ‘/view/asterisk-addons/tags/1.6.0-beta3’: 301 Moved (svn.digium.com)
root@core:/kituri/voip/asterisk-1.6# svn co svn.digium.com/view/asterisk-add … .6.0-beta3
svn: PROPFIND request failed on '/view/asterisk-addons/tags/1.6.0-beta3’
svn: PROPFIND of ‘/view/asterisk-addons/tags/1.6.0-beta3’: 301 Moved (svn.digium.com)
root@core:/kituri/voip/asterisk-1.6#

Hope that I will find it soon at:
asterisk.org/downloads

Change view to svn

For example:

svn co http://svn.digium.com/svn/asterisk-addons/tags/1.6.0-beta3 ./addons-1.6.0-beta3

The SVN is working now, I was able to download addon’s beta 3, but I receive the same error like with beta 2:

[Apr 2 09:58:18] WARNING[24311]: loader.c:640 inspect_module: Module ‘chan_mobile.so’ was not compiled with the same compile-time options as this version of Asterisk.
[Apr 2 09:58:18] WARNING[24311]: loader.c:641 inspect_module: Module ‘chan_mobile.so’ will not be initialized as it may cause instability.
[Apr 2 09:58:18] WARNING[24311]: loader.c:679 load_resource: Module ‘chan_mobile.so’ could not be loaded.
[Apr 2 09:58:18] WARNING[24311]: loader.c:640 inspect_module: Module ‘app_fax.so’ was not compiled with the same compile-time options as this version of Asterisk.
[Apr 2 09:58:18] WARNING[24311]: loader.c:641 inspect_module: Module ‘app_fax.so’ will not be initialized as it may cause instability.
[Apr 2 09:58:18] WARNING[24311]: loader.c:679 load_resource: Module ‘app_fax.so’ could not be loaded.
[Apr 2 09:58:18] WARNING[24311]: loader.c:640 inspect_module: Module ‘app_saycountpl.so’ was not compiled with the same compile-time options as this version of Asterisk.
[Apr 2 09:58:18] WARNING[24311]: loader.c:641 inspect_module: Module ‘app_saycountpl.so’ will not be initialized as it may cause instability.
[Apr 2 09:58:18] WARNING[24311]: loader.c:679 load_resource: Module ‘app_saycountpl.so’ could not be loaded.
[Apr 2 09:58:18] WARNING[24311]: loader.c:640 inspect_module: Module ‘format_mp3.so’ was not compiled with the same compile-time options as this version of Asterisk.
[Apr 2 09:58:18] WARNING[24311]: loader.c:641 inspect_module: Module ‘format_mp3.so’ will not be initialized as it may cause instability.
[Apr 2 09:58:18] WARNING[24311]: loader.c:679 load_resource: Module ‘format_mp3.so’ could not be loaded.
[Apr 2 09:58:18] WARNING[24311]: loader.c:640 inspect_module: Module ‘cdr_addon_mysql.so’ was not compiled with the same compile-time options as this version of Asterisk.
[Apr 2 09:58:18] WARNING[24311]: loader.c:641 inspect_module: Module ‘cdr_addon_mysql.so’ will not be initialized as it may cause instability.
[Apr 2 09:58:18] WARNING[24311]: loader.c:679 load_resource: Module ‘cdr_addon_mysql.so’ could not be loaded.
[Apr 2 09:58:18] WARNING[24311]: loader.c:640 inspect_module: Module ‘app_addon_sql_mysql.so’ was not compiled with the same compile-time options as this version of Asterisk.
[Apr 2 09:58:18] WARNING[24311]: loader.c:641 inspect_module: Module ‘app_addon_sql_mysql.so’ will not be initialized as it may cause instability.
[Apr 2 09:58:18] WARNING[24311]: loader.c:679 load_resource: Module ‘app_addon_sql_mysql.so’ could not be loaded.
[Apr 2 09:58:18] WARNING[24311]: loader.c:640 inspect_module: Module ‘res_config_mysql.so’ was not compiled with the same compile-time options as this version of Asterisk.
[Apr 2 09:58:18] WARNING[24311]: loader.c:641 inspect_module: Module ‘res_config_mysql.so’ will not be initialized as it may cause instability.
[Apr 2 09:58:18] WARNING[24311]: loader.c:679 load_resource: Module ‘res_config_mysql.so’ could not be loaded.

Asterisk 1.6 beta 6 + addons beta 3 = ok