Incoming call problem with nufone

I am having a problem with incoming calls from nufone.

iax.conf contains the following

register => [nufone] type=user secret=mypassword context=inbound
extensions.conf contains

exten => my10digit#,1,Answer
exten => my10digit#,2,Dial(SIP/bt101,15)
exten => my10digit#,3,Hangup

When a call comes in asterisk says

There is an extra ‘@’ on the end of my number in the error message.
Does anyone have any ideas on how to get this to accept the incoming call.


You could try to replace in [inbound]
my10digit# to s
exten => s,1,Answer

I tried replacing my10digit# with s, and I get the same result as before. Any other ideas?

not yet.
i have the same problem when connecting 2 asterisk using iax

Do iax debug and make inbound call
iax no debug to stop

see what the error is…

OK I get the following when the call is attempted:

Thanks Bubba,
It looks like I figured it out once I read the debug.
The debug said they were reporting user=NuFone, and my entry in iax.conf was [nufone], since unix sees a difference, it was not authenticating. I changed iax.conf and the call goes through.