IAXy (S101I) disconnects from network every minute

So far so good: I’m able to send and receive calls on the IAXy from inside and outside the network. The IAXy is inside the firewall for now so I can clear out all the bugs first.

Issue: Every minute or so, the IAXy would disconnect from the network for about an minute, then reconnect to the network. Not sure if it’s rebooting or just disconnecting. When I run “ping -t 10.0.10.XX” I would see it disconnect then reconnect after a minute.

On the asterisk server, all I see is this repeated every minute or so:

– Registered IAX2 ‘551’ (AUTHENTICATED) at 10.0.10.XX:4569

I’m wondering if I just have a bad IAXy box and it just needs to be replaced. Thanks in advance!



I replaced the AT&T speaker phone Model 950 with a simple Radioshack ET-3222 phone and the problem went away; no more network disconnection every minute.

twaathome.com/catalog/dept_i … el_950.htm

radioshack.com/sm-white-big- … 02451.html

My question now is this: how do I know which kinds of Analog Phones will work with the IAXy? I will post it in a new thread.


I spoke too soon. About an hour after I replaced the phone, the symptoms started happening again! Network disconnecting every minute. Sigh.

what happens if you leave no phone plugged in? sounds to me like the iaxy is dying (the off the air, on the air probably indicates it’s rebooting…)

I power-cycled the IAXy box, then verified I could send a receive calls on it. I then disconnected the analog phone from the IAXy. It pingged fine for about an hour, then it started disconnecting and reconnecting every minute or so again! So it’s not the analog phone.

Do I have a defective IAXy?


As a comercial product, what was the answer from Digium? Is there the possibility of firmware upgrade?
I have a PAP2T that had similar problems and after a firmware upgrade the problems went away…

The IAXy S101i upgrades its firmware directly and automatically from the Asterisk server. My asterisk server (Version says it has Firmware 23.

localhost*CLI> iax2 show firmware
Device Version Size
iaxy 23 39360

The command “iax2 debug” should show the firmware version deployed on the IAXy but it does not display. I only get this:


So I’m wondering if the IAXy has an old firmware, but I don’t know of another way to find out.


I got the IAXy working OUTSIDE the office firewall. I will start testing it from home tonight and see if the problem persists outside the firewall. I suspect the DHCP Server or the Dell Switch may have something to do with the disconnect-every-minute problem. I will update later.

I took the IAXy home, and at first it worked fine. Not sure when it started, but after a few hours, it started doing the same behavior: it would disconnect then reconnect to the network after about a minute. One odd detail I would like to mention: just when it’s about to die, on the handset I hear the dial tone slowly “die” like it was losing power. Then a couple of clicks. Then dead. I suspect now that it’s a bad IAXy. Sending it back to Digium today.

Sent the IAXy back to Digium and got the replacement. Works great!

I’ve been having the same problem with 2 of my IAXys…I guess I need to call Digium and let them know…


If you have more than one iaxy on the same subnet, check their MAC addresses. I received an iaxy earlier this year that had the MAC set to all zeros. Easiest way to do that is to ping the unit, then immediately dump your arp table.

Also, check your firewall to see if it’s timing the connection out - it shouldn’t if traffic is moving through, but disconnects after one minute can be indicative of a nat issue.