How to use MixMonitor's "i option"

Hi All.

According to this page(,
I try to use “i option” and get mix_monitor_id.
but I got empty value.

Am I wrong something?

This is my extensions and log.


   same => n,MixMonitor(${rfraw},ab,/listcall/agi/ ^{rfraw},i(${mix_monitor_id}))
   same => n,NoOp(mix_monitor_id=${mix_monitor_id})


    -- Executing [outbound_out_channel_id_event@ctx_listcall:22] MixMonitor("SIP/cpn_05053065175-00000001", "/listcall/recfile/outbound/1/20170926/3/20170926_141401-05053065175-05052424142-lc_1_3_t.wav49,ab,/listcall/agi/ ^{rfraw},i(mix_monitor_id)") in new stack
    -- Executing [outbound_out_channel_id_event@ctx_listcall:23] NoOp("SIP/cpn_05053065175-00000001", "mix_monitor_id=") in new stack

Thanks your help.

When you reference a variable you can call it by its name, but when you refer to a variable’s value, you have to use the dollar sign and brackets around the variable name.

same=>n,Noop(id for ${monitorid})

thank you, I fix it and I did “i option” to wrong place also.
after fixed it, I got mix_monitor_id’s variable.
Thank you.

1 Like