How to set IMAP users?

I’ve these 2 messages:

[Mar 19 09:28:20] WARNING[3467]: app_voicemail.c:2500 inboxcount: IMAP user not set for mailbox 5151
[Mar 19 09:28:20] NOTICE[3467]: app_voicemail.c:3002 leave_voicemail: Can not leave voicemail, unable to count messages

Someone knows how can I set IMAP users in my dialplan or voicemail.conf??
Please help me!!!
Thanks a lot,

Pask

You probably want to post segments of your voicemail.conf.

[general]
format=gsm
serveremail=asterisk
imapserver=localhost
imapfolder=Voicemail
imapflags=notls
imapport=143
authuser=pasquale
authpassword=cassanelli
attach=yes
maxmsg=100
maxmessage=180
minmessage=3
skipms=3000
maxsilence=10
silencethreshold=128
maxlogins=5

tz=Rome
attach=yes
saycid=yes
sendvoicemail=yes

[zonemessages]
newzonemessage=Europe/Rome|‘vm-received’ Q ‘digits/at’ IMp

[utenti]

5151 = 2222,Frau Sbrau,pasquale@sistemi.eos.it
23 = 23,pasquale,imapuser=pasquale|imappasswd=cassanelli

upon I’ve posted my voicemail.coonf file. Here below there’s the messages on the CLI>
First WARNING message was resolved!
I’ve set a IMAP server (it’s necessary), so I’ve created a file in my home named INBOX (-rw-rw-rw-).

-- Called 23
-- SIP/23-081d9838 is ringing
-- Nobody picked up in 10000 ms
-- Executing [23@maincall:4] SendText("SIP/24-081d4240", "SALVE!!!") in new stack
-- Executing [23@maincall:5] GotoIfTime("SIP/24-081d4240", "13:00-13:59|*|*|*?macro-response|s|1") in new stack
-- Executing [23@maincall:6] GotoIf("SIP/24-081d4240", "0?5") in new stack
-- Executing [23@maincall:7] VoiceMail("SIP/24-081d4240", "u23@utenti") in new stack

[color=red][Mar 20 11:32:31] WARNING[3459]: app_voicemail.c:6794 vm_exec: Prefixing the mailbox with an option is deprecated (‘u23@utenti’).
[Mar 20 11:32:31] WARNING[3459]: app_voicemail.c:6795 vm_exec: Please move all leading options to the second argument.[/color]
– <SIP/24-081d4240> Playing ‘vm-theperson’ (language ‘it’)
– <SIP/24-081d4240> Playing ‘digits/2’ (language ‘it’)
– <SIP/24-081d4240> Playing ‘digits/3’ (language ‘it’)
– <SIP/24-081d4240> Playing ‘vm-isunavail’ (language ‘it’)
– <SIP/24-081d4240> Playing ‘vm-intro’ (language ‘it’)
[[color=red]Mar 20 11:32:41] ERROR[3459]: app_voicemail.c:8489 mm_log: IMAP Error: Can’t open mailbox {localhost:143/imap/pasquale/notls/user=pasquale}INBOX: invalid remote specification
[Mar 20 11:32:41] ERROR[3459]: app_voicemail.c:4662 init_mailstream: Can’t connect to imap server {localhost:143/imap/pasquale/notls/user=pasquale}INBOX
[Mar 20 11:32:41] ERROR[3459]: app_voicemail.c:2542 inboxcount: IMAP mailstream is NULL[/color]
[Mar 20 11:32:41] NOTICE[3459]: app_voicemail.c:3002 leave_voicemail: Can not leave voicemail, unable to count messages
== Spawn extension (maincall, 23, 7) exited non-zero on ‘SIP/24-081d4240’
– Executing [h@maincall:1] Hangup(“SIP/24-081d4240”, “”) in new stack
== Spawn extension (maincall, h, 1) exited non-zero on ‘SIP/24-081d4240’

Here is my voicemail.conf
imapserver=192.168.8.15
imapfolder=Inbox
imapflags=notls
expungeonhangup=yes
authuser=imap
authpassword=ccv4me

2992 =>0131,Erik,erikwilhelmsen@ccvonline.com,|imapuser=ewilhelmsen

I am able to telnet on port 143 to the IMAP server from Linux just fine. But when I start asterisk I get these errors.

[Mar 20 08:31:31] ERROR[15359]: app_voicemail.c:8489 mm_log: IMAP Error: Can’t open mailbox {192.168.8.15:143/imap/imap/notls/user=ewilhelmsen}INBOX: invalid remote specification
[Mar 20 08:31:31] ERROR[15359]: app_voicemail.c:4662 init_mailstream: Can’t connect to imap server {192.168.8.15:143/imap/imap/notls/user=ewilhelmsen}INBOX
[Mar 20 08:31:31] ERROR[15359]: app_voicemail.c:2542 inboxcount: IMAP mailstream is NULL

I am trying to connect to a MS Exchange IMAP server. I have also tried Dovecot IMAP.
If anyone could help I would appreciate it.

Thanks,
Erik