How to remove @provider from phone number

Hi, I am just new to asterisk and I have some problems how to configure it.

I have astersik, one sip phone and my application with sip interface. I simply register the phone to asterisk as 1000 and my application as 2000 (before that I hav created sip account in sip.conf).

Looking “sip show peers” I know that both are registered correctly

But when I try to make call from sip phone to my application I get that the caller number is 1000@provider insted of only 1000.

I suppose that the postfix “@provider” is attached by asterisk. But when my app tries to call back using “1000@provider” the call will not be created because asterisk does not know any pho number “1000@provider”. So I must at first remove the postfi and than make a call.

So is there any possibilty how to set asterisk to NOT use this @provider postfix??

Thanks for any reply

@provider is added by the provider, and is, I believe, required by the SIP standards.

Asterisk, by default, ignores the @provider when routing calls.

Which version of Asterisk are you using?

Thanks for you fast reply

well I am using
Asterisk built by uncovsky @ hel on a i686 running Linux on 2008-09-18 07:23:48 UTC

I know it is a little bit old version but I cannot upgrade asterisk to newer version because I have not access right :astonished:))

Do you think that newer version will igonre the @provider??



That version isn’t that old. All versions should ony use the user part of the address, although you can configure Asterisk to only accept calls to its own IP address/domain name. Do you have any SIP options containing “domain”. You probably shouldn’t. I think there is also an option to set the context according to that part of the address, but I can’t find it at the moment.

Of course, you can always re-write the caller ID in the dial plan.