How to remove ivr

I am using goautodial with digium card.outbound calling is working fine with ivr.
can u suggest me how to remove ivr.
Thanks in advance

Haaaaaaaave you talked to the people that you downloaded goautodial from? Try them first.

Hi Malcolm Davenport,

I have used same goautodial iso with sangoma pri card.It was connecting to reciever directcly without ivr.But if i use digium pri card ivr is the problem.

Thanks in advance

This is a peer support forum, not a forum for the open source Asterisk code, not a forum a forum managed by Digium, about their hardware.

IVRs ar generally constructs created by dialplans, not something that is intrinsic to Asterisk, so you need to seek support, for doing things with them, from the people who wrote them (the gotoautodial people, in this case).

Digium do provide some free support for their hardware, but that is via their commercial web site and on a one to one basis. I don’t know how far they will go in supporting you through through the consequences of replacing a Sangoma card with a Digium one, but to the extent that they will do so, you need to pose the problem in terms of fixing the consequences of that change and not assume that disabling a gotoautodial “ivr” is the appropriate minimum fix.


I have solved the ivr issue.Outbound is working fine.

In bound Error:
Extension ‘XXXX’ in context ‘from-pstn’ from ‘XXXXXX’ does not exist. Rejecting call on channel 0/1, span 1

Calls are hitting the scripts,
if i change ‘context=from-pstn’ to context=‘trunkinbound’ it may work i guess.
But Where the digium config files are found?

Thanks in advance.

If Asterisk is built with default options, the Asterisk configuration files are in /etc/asterisk. Normal installations do not have any specifically Digium ones.

However, where you have a GUI, the GUI normally takes ownership of those files, and any manual changes may break the GUI. Typically the GUI files have includes for user customisation, but there will be limits to what customisation is allowed.

Thank you david.
Earlier i have changed ‘context=default’ to ‘context=trunkinbound’ in sip.conf.But the error was same.
Where actually the line context=“from-pstn” is found?if i change that to “context=trunkinbound” the inbound calling may work.
Any suggestions sir?

Thanks in advance

Use grep.

You are making this difficult for yourself by treating it as an Asterisk issue when it is acutally a gotoautodial one, or one with something that that uses.