How can I cancel the ringtone sound in customer?

Hello, Guy:
I implemented asterisk for a call center. this company asks me cancel the ringtone from customer side. when customer calls in, the IVR will directly play sound file without ringtone sound like '‘dudu’. so the customers can hear the IVR directly. I think this sound or ringtone is generated from telcom company not asterisk server. if it is generated from asterisk server, how do i config it? anyone knows this, please give me a hand!

Do you see ringing on the CLI during the call?

depends on a number of factors. First if you are using analog trunks they will probably hear a ring no matter what so get used to it.

if Answer() is the very first thing in your script, that will minimize the ring as much as * can do pretty much.
However it may not be possible to completely eliminate the ring as this may be generated by your telco as it connects the call internally.

I’ve the same issue as well and added in Answer() but it still ring (“dudu”) twice before it went into the IVR.

It seems like the asterisk pick up once i make the call, as i can see Starting Switch Zap/2-1 before my phone start to give “dudu”.

Any idea?

If you have analog trunks, Asterisk will wait until after the 1st ring to answer. This is because the CallerID FSK chirp is sent directly after the 1st ring, but is not sent if the call is answered before it goes out. Thus, Asterisk waits for the CallerID chirp to come in before starting dialplan execution. The only solution to this is to turn off CallerID for your analog lines, however this will (duh) prevent those lines from getting any CallerID data. It also won’t completely eliminate the ring for a caller, as the telco generally starts playing the ring slightly before the other side starts ringing.

Hoep that helps!


It’s working now… thanks a lot!