High ring current destroying / damaging FXO modules

We were facing a problem before where callers would call in, asterisk reports that the call gets answered by the IVR but the caller still hears the ringing tone. When a Digium FXO module starts behaving this way, it would never work correctly again.

We finally figured out the problem when we tried moving to a commercial solution and their modules died the same way and the company did some diagnostics.

It was caused by high ring currents. The ring current is really high because we’re located a few feet away from the phone company’s phone switch.

We’ve tried using surge protectors to limit the currents but that didn’t work.

Has anyone faced the same problem with high ring currents and found a good solution to control it?


try calling the telco and ask them to reduce your ringing voltage. They should be able to do this.

If not you might try putting additional load on the line- get some bell ringers (the kind that have a real metal bell, don’t take a power plug, and ring when the phone does. Now remove the bell and plug it in. When the line rings ti will still use up power (usually 1.0REN for a bell) moving the clapper back and forth, but it will make very little noise.


I think you mean voltage. But you will need to speak to the telco though to get it sorted. If as you say its i the co then have a word with one of the techs.